[SOLVED] RB941-2nd bricked after package upgrade


Be extra careful with updating!

After update packages via luci and rebooting my device is... down.

Router: rb941-2nd

No any possibility to connect via ssh or telnet.

Hard reset won't work.
No ping.
Just some answer: request Announcement USER1 (browser protocol) name query NB (nbns protocol) (source ip) ICMP Host unreachable. (LLNM protocol) standard query 0x023d,0x050e,0x9d75 (NBNS protocol) NB ISATAP<00>

Method of hard reset: quick pressing reset button and long (10-20 sec). All ports 1(wan) and 2-4(lan).

Anyone know how to solve it?

#openwrt bricked router

updating what, from what ?

try https://openwrt.org/toh/mikrotik/rb941-2nd#run_openwrt_in_ram

Updating? Or upgrading packages?

packages via luci

that can be a bad thing, depending on what openwrt version you were running, and how/what you did.

Right...but did you update packages, or upgrade packages?

Big difference.

I don't remember exactly.. 19.07 may be

Still haven't answered the question on updating or upgrading packages...

Describe the steps you did in LuCI.

usually I use opkg update via ssh. At this time via luci... It wasn't upgrading OpenWrt firmware.

doesn't seem to matter though, since the device's dead ...

perhaps we should focus on the recovery ?

1 Like

Yes, recovery will be great. I think it's alive. But no connection.
2Ols NavyGuy: Update list -> Updates -> Upgrade... Reboot

For future reference...

OK -

Not good -

That's why it bricked.

See the above screen shots.

Try to restore the original firmware using an older version of netinstall.


1 Like

Also this -


1 Like

God bless you!
6.48.6 ver of netinstall recover it.

2 all:

Many thanks for everybody!
Now it is RouterOS))


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.