[Solved] Print Server p910nd not working with 2 USB printer connected at the same time

I am seeking help getting my usb printers working again with p910nd server.

Both usb printers were working previously until I recently update the firmware OpenWrt23.05.2 r23630-842932a63d and reinstalled p910nd.

Now, only one USB printer is working at a time (having to disconnect one of the printer)

/dev/usb/lp1 port 0 is connected to USB-3 port for Dymo Label 4XL -> Add Printer to MBP

/dev/usb/lp0 port 1 is conneced to USB-2 port for Dymo Label 450 -> Add printer to MBP

I can only add one of the printer to my MBP computer at a time.
Previously, I can add both, and having both connected and working at the same time.
Now, I have to disconnect one in order for one to work.

root@OpenWrt:~# opkg list-installed | grep usb
brcmfmac-firmware-usb - 20230804-1
kmod-phy-bcm-ns-usb2 - 5.15.137-1
kmod-phy-bcm-ns-usb3 - 5.15.137-1
kmod-usb-bcma - 5.15.137-1
kmod-usb-core - 5.15.137-1
kmod-usb-ehci - 5.15.137-1
kmod-usb-ledtrig-usbport - 5.15.137-1
kmod-usb-ohci - 5.15.137-1
kmod-usb-printer - 5.15.137-1
kmod-usb-storage - 5.15.137-1
kmod-usb-storage-uas - 5.15.137-1
kmod-usb-xhci-hcd - 5.15.137-1
kmod-usb2 - 5.15.137-1
kmod-usb3 - 5.15.137-1

root@OpenWrt:~# ls /dev/usb/lp*
/dev/usb/lp0 /dev/usb/lp1

There has already been a fix for that in Snapshot: https://github.com/openwrt/packages/commit/152d80ce1326d0b1fee8e324ec8e68dd9f44cf4a

thanks to @NPeca75 :slight_smile:

1 Like


if you want to stick with 23.05.x you could put these in rc.local


test -e /etc/init.d/p910nd && {
    grep -q 'procd_open_instance $DAEMON_NAME' /etc/init.d/p910nd && {
        killall -9 p910nd
        sed -i 's/procd_open_instance $DAEMON_NAME/procd_open_instance/g' /etc/init.d/p910nd
    sleep 10 && /etc/init.d/p910nd restart > /tmp/log_startup_p910nd 2>&1 &

exit 0

please notice that option
runas_root must be '1'

1 Like

glad that it has been fixed, and I am grateful for the quick reply, as I have spent last 2 days trying to figure what I have missed.
I have read the page you sent, but I am completely lost. please help me with steps by steps. I have a very limited knowledge.

thanks for your help, how do I put the script into rc.local?
sorry, I dont know much.

Maybe backport/cherry pick it for 23.05?
At least it will be in the next 23.05 release

It worked, I put your script into local start-up (System > Start up > Local Startup > "This is the content of /etc/rc.local" field
Save and Restart Router, everything is now working as expected.

Thank you so much for your help.


Ok :slight_smile:

i am glad that you get it working

please consider to mark this topic as [Solved] and answer as "solution"

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.