[Solved] Port forwarding via virgin media (modem mode) [Solved]


I thought what i was doing was easy... It seemed it!

I have my Virgin router in Modem mode. Thats connected to the WAN port of my Linksys WRT1900ACS (23.0.5). Internet working fine, everything great, Source Zone is WAN (I've disabled WAN6 and USBWAN for simplicity - see pic below)

I'm trying to set up openvpn, so port 1194 to my internal address, from the WAN - simple. (done it a million times with other routers). Admitedly, thats going from another openwrt device (Linksys WRT1300ACS (23.0.5)), but all ports (including WAN) are set to be on the br-lan port, and access to said server works fine, no firewall enabled as internal, so i don't think its the issue. (i can re-locate that device to completely remove from the picture)

Advanced settings are vanilla.

I also tried adding traffic rules - don't think its this however!

Any ideas welcomed. I have googled a fair bit, i promise!

Do you have a public IP? What are the first two octets of the IP address shown in the main status page in the IPv4 uplink? (in bold: aaa.bbb.ccc.ddd)

Hi Psherman, annotated :slight_smile: Thanks

IPv4 Upstream

Protocol: DHCP client
Address: 82.24.ccc.ddd/22 (redacted)
Gateway: 82.24.ccc.ddd (redacted)
DNS 1:
DNS 2:
Expires: 6d 20h 54m 58s
Connected: 3h 5m 2s

Great... you do have a public IP.

Please confirm that you have a host at that is awake and listening for inbound connections on TCP and/or UDP port 1194 (I'm guessing this is OpenVPN). The service must be running and ready to accept connections.

If you can confirm the above, let's look at your config as the next step:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/firewall

Interestingly, i have 2 ports open, 5000 and port 1194.

Port 5000 was open internally (telnet test) but wouldn't work externally
Port 1194 was not open internally.

I rebooted the device (synology)

Port 5000 opened both internally and externally
Port 1194 still closed internally and externally, but strangely works.

Thanks for all your help. Now i've got a known good configuration, i guess i can just swap out the virgin router (modem), to another device and it should repeat. Good to know where to look, ie ipv4 upstream :slight_smile: Thanks again!

If the server is on UDP 1194, and the probe happens with TCP 1194, it will return closed since it won't get a response.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.