azu
August 12, 2023, 10:24pm
1
Hello!
I have just downloaded and installed the current release candidate 23.05.0-rc2 (because I guess it will be stable enough for my initial standard configuration).
I simply would like to bridge LAN and Wireless connections and have a DHCP server offering addresses to that bridge, nothing special. But I must be missing something because clients do not get an address.
Please find below some configs which might help you to help me : ) Please let me know if anything else could be needed.
Thank you!
/etc/config/dhcp
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
list dhcp_option '6,192.168.1.2'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
/etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd96:4dfd:1984::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'eth0.2'
option macaddr '64:66:6f:b3:91:86'
config interface 'wan'
option device 'eth0.20'
option proto 'dhcp'
config interface 'wan6'
option device 'eth0.20'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 4 5'
option vid '1'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 1t'
option vid '20'
/etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/ahb/18100000.wmac'
option channel '1'
option band '2g'
option htmode 'HT20'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'onessid'
option encryption 'psk2'
option key 'thisisnotmypassword'
config wifi-device 'radio1'
option type 'mac80211'
option path 'pci0000:00/0000:00:00.0'
option channel '36'
option band '5g'
option htmode 'HT20'
option cell_density '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'anotherssid'
option encryption 'psk2'
option key 'thisisnotmypassword'
Nothing obvious here... let's see your firewall file.
Also, is it possible there is another DHCP server on your network? For example, if you're running a pihole, does that have a DHCP server enabled?
azu
August 12, 2023, 10:51pm
3
Thanks.
Nope, I don't have another DHCP server.
/etc/config/firewall
config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
option enabled '0'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
option enabled '0'
No problems in the firewall file.
Are you connecting by Ethernet? Is there anything between the router and the computer? Have you tried a fresh cable?
azu
August 12, 2023, 11:09pm
5
Yes. And I don't get a dynamic address. I don't get it through wireless either.
Nope, there is nothing in between.
It's not a connectivity issue, it woks ok if I configure a static address in the client - that's how I access the router.
Have you restarted the router?
Before you try that, is there anything in the logs?
logread -e dhcp
azu
August 12, 2023, 11:43pm
7
Yes, I did reboot.
There you go:
root@myrouter:~# logread -e dhcp
Sat Aug 12 20:13:53 2023 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/network
Sat Aug 12 20:13:54 2023 user.notice ucitrack: Setting up /etc/config/odhcpd reload dependency on /etc/config/dhcp
Sat Aug 12 20:13:56 2023 user.notice ucitrack: Setting up /etc/config/dhcp reload dependency on /etc/config/system
Sat Aug 12 20:14:00 2023 daemon.notice netifd: wan (2030): udhcpc: started, v1.36.1
Sat Aug 12 20:14:03 2023 daemon.notice netifd: wan (2030): udhcpc: broadcasting discover
Sat Aug 12 20:14:06 2023 daemon.notice netifd: wan (2030): udhcpc: broadcasting discover
Sat Aug 12 20:14:09 2023 daemon.notice netifd: wan (2030): udhcpc: broadcasting discover
What device are you using?
ubus call system board
When you installed the 23.05.0-rc2 firmware, did you keep settings from a previous version of OpenWrt? If so, what version did you come from?
azu
August 13, 2023, 12:23am
9
TP-Link TL-WDR4300 v1.6
root@myrouter:~# ubus call system board
{
"kernel": "5.15.118",
"hostname": "myrouter.here",
"system": "Atheros AR9344 rev 2",
"model": "TP-Link TL-WDR4300 v1",
"board_name": "tplink,tl-wdr4300-v1",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.0-rc2",
"revision": "r23228-cd17d8df2a",
"target": "ath79/generic",
"description": "OpenWrt 23.05.0-rc2 r23228-cd17d8df2a"
}
}
azu
August 13, 2023, 12:29am
10
Nope. It's a handmade fresh configuration.
Does this mean a custom image, or the standard image + configuration after you installed it?
If the latter, what happens if you reset to defaults?
If the former, have you tried a standard image?
azu
August 13, 2023, 12:47am
12
Current release candidate 23.05.0-rc2 image + handmade fresh configuration.
If I reset to defaults, the DHCP server works. There must be something in my configuration.
azu
August 13, 2023, 12:57am
13
Must leave now, I'll carry on in some hours. Thanks.
Yup... so the next logical question will be: what did you change?
I didn't see anything of obvious, but clearly something else was going on, so we'd need to know what changed from defaults.
azu
August 13, 2023, 3:10pm
15
Found it, or kind of.
In the dhcp config I posted, I did not include some innocent static leases as I considered them irrelevant. I think the problem was the name of one of them.
I copied the configuration of a static lease from a backup. It wrongly read option name 'torbridgeƻocal'
(the host is a Tor Bridge). When pasting it into the router, it read option name 'torbridge..ocal'
. And that seems to be the the mysterious cause of the problem. Somehow it did not like that string.
Then I did many tests in order to find out what the problem on that string really is, but I surrendered as it was driving me insane. I got very unsatisfying weird results. I guess my tests were not properly made. I ended up with option tor-br.local
and it seems to be stable now...
Thank you for your help!
Glad you found the issue.
If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks!
system
Closed
August 23, 2023, 3:40pm
17
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.