[SOLVED] Opkg update does not work after mesh installation

i created the mesh network on arduino yun (supports openwrt). initially opkg update works fine, but after configuration of mesh is done; opkg update does not work. each of nodes has internet access if checked from web browser(computer connected to node as client) and luci works fine too. all ping also works fine as above. but opkg update and opkg install does not work; also this device doesnot have wan6 (disabling wan6 can help in some devices)

checked many places they say opkg update fails if network does not have internet access( which i have and ping also works) or /etc/config/network is not configured well ( how would i get internet access if configuration was not ok)...?

Also if i check from luci i can see that Wan interface is down (due to bridge between eth0 and eth1) but internet works fine.

my configuration is

config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr ''
option netmask ''

config globals 'globals'

option ula_prefix 'fd3c:e0d9:3614::/48'

config interface 'lan'

option type 'bridge'
option proto 'static'
option ipaddr ''
option netmask ''
option ip6assign '60'
option ifname 'eth0 bat0 eth1' 

#this bridged so that eth1 gets internet from wan(ethernet) and gives to eth0(lan wifi) which works fine and bat0 is for mesh

config interface 'mesh'

  option ifname 'adhoc0'
  option mtu '1532'
  option proto 'batadv'
  option mesh 'bat0'

config interface 'wan'

option proto 'dhcp'
option _orig_ifname 'eth1'
option macaddr 'A8:40:41:11:EB:AC'
option ifname 'eth1'

@hnyman @tmomas can you please help..?
my connection configuration is:
internet-------------ISP router( internet port of d link ac1200)( (wired ethernet to eth1 of node 1)----node1(eth0=wifi, eth1=wired ethernet)

for above problem i tried multiple options:

a) turn of bridge between lan(eth0 and bat0) and wan(eth1 wired ethernet from internet router) then opkg update works i.e..,device(node) gets internet for itself from wan(wired ethernet) but internet on lan(wifi) is off......during this time lan and wan has separate ip(wan given by dhcp of dlink router and lan with static as specified above)

b) continue with bridge; ip of wan(wired ethernet) disappears (even though interface remains up) but wifi has internet with static ip as specified above.

No knowledge of mesh etc.

But one thing might be ipv6 routing.
Check with nslookup if your DNS gives ipv6 address for downloads.openwrt.org.
If yes, then that is preferred by opkg (instead of ipv4).
So if you have misconfiguration in ipv6, opkg may fail while ipv4 ping works ( and ipv6 ping fails).
Either configure also ipv6 properly, or do not assign an ipv6 address to the router.
Just a guess, but might be worthwhile to check.

the problem was with DNS server address so giving DNS server address as your internet providing router address or google address( will solve this problem.
Also give gateway address (your router address)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.