Opkg update failed to download the package list ping ok

Hello,

I have a problem to update pkg list, here is output:

root@Router:~# opkg update
Downloading http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/generic/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/generic/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/base/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/base/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/luci/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/luci/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/routing/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/routing/Packages.gz

Downloading http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/telephony/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/telephony/Packages.gz

Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/generic/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.
root@Router:~# wget http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/telephony/Packages.gz
Downloading 'http://downloads.openwrt.org/releases/18.06.2/packages/mips_24kc/telephony/Packages.gz'
Connecting to 2a01:4f8:202:43ea::2:80
Connection error: Connection failed

root@Router:~# ping  downloads.openwrt.org
PING downloads.openwrt.org (148.251.78.235): 56 data bytes
64 bytes from 148.251.78.235: seq=0 ttl=52 time=29.328 ms
64 bytes from 148.251.78.235: seq=1 ttl=52 time=29.048 ms
64 bytes from 148.251.78.235: seq=2 ttl=52 time=28.789 ms
64 bytes from 148.251.78.235: seq=3 ttl=52 time=28.549 ms
64 bytes from 148.251.78.235: seq=4 ttl=52 time=28.374 ms
64 bytes from 148.251.78.235: seq=5 ttl=52 time=28.402 ms
64 bytes from 148.251.78.235: seq=6 ttl=52 time=30.965 ms
64 bytes from 148.251.78.235: seq=7 ttl=52 time=28.301 ms
64 bytes from 148.251.78.235: seq=8 ttl=52 time=28.044 ms
root@Router:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 64:D1:A3:1D:49:F3
          inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
          inet6 addr: fe80::66d1:xxxxxxxx:xxx/64 Scope:Link
          inet6 addr: fd29:eae8:b670::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:284402 errors:0 dropped:0 overruns:0 frame:0
          TX packets:467353 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:27962023 (26.6 MiB)  TX bytes:614078938 (585.6 MiB)

eth0      Link encap:Ethernet  HWaddr 4A:DD:3F:A9:52:4D
          inet6 addr: fe80::48dd:xxxxxxxx:xxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1090578 errors:0 dropped:0 overruns:0 frame:0
          TX packets:471467 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:658831011 (628.3 MiB)  TX bytes:273724384 (261.0 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr 64:D1:A3:1D:49:F3
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:108444 errors:0 dropped:22 overruns:0 frame:0
          TX packets:211059 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:16522156 (15.7 MiB)  TX bytes:238779118 (227.7 MiB)

eth0.2    Link encap:Ethernet  HWaddr 64:D1:A3:1D:49:F5
          inet addr:109.15.14.71  Bcast:109.15.15.255  Mask:255.255.240.0
          inet6 addr: 2a00:6200:80:xxxxxxxxxxxxxxx:xxx/64 Scope:Global
          inet6 addr: fe80::66d1:a3ffxxxxxxx:xxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:569850 errors:0 dropped:0 overruns:0 frame:0
          TX packets:243249 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:602822183 (574.8 MiB)  TX bytes:27713797 (26.4 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:7130 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7130 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:532003 (519.5 KiB)  TX bytes:532003 (519.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 64:D1:A3:1D:49:F4
          inet6 addr: fe80::66d1:xxxxxxx:xxxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10304 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:767029 (749.0 KiB)

wlan1     Link encap:Ethernet  HWaddr 64:D1:A3:1D:49:F3
          inet6 addr: fe80::66d1:xxxxxxx:xxx/64 Scope:Link
          inet6 addr: fe80::66d1:xxxxxxx:xxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:175973 errors:0 dropped:0 overruns:0 frame:0
          TX packets:275588 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13904459 (13.2 MiB)  TX bytes:383450902 (365.6 MiB)

I tried to disable Request IPv6-address from WAN6, I been able to update but same error come.
If I disable WAN6, all work ok.

Do you know why WAN6 cause wget and opkg update fail please? It is probably ipv6 related problem.

It looks like you have an IPv6-address.

Why don't you try to enable and utilize it properly?

ifup wan6; sleep 10; ifstatus wan6
ip -6 a; ip -6 r; ip -6 ru
traceroute6 openwrt.org
1 Like

It is trying to download from IPv6 and fails.
Try the commands posted by @Hegabo and we'll see what can be the issue there.

2 Likes

It's not me! It's him! @vgaetera

1 Like

oops :laughing:
Sorry for that @vgaetera...

2 Likes

Thanks for answers

root@Router:~# ifup wan6; sleep 10; ifstatus wan6
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 10,
        "l3_device": "eth0.2",
        "proto": "dhcpv6",
        "device": "eth0.2",
        "updated": [
                "addresses",
                "routes"
        ],
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "2a00:6200:80:2b01:xxxxxxxxxx:xxxx",
                        "mask": 64,
                        "preferred": 604790,
                        "valid": 2591990
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2a00:6200:80:2b01::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 2591990,
                        "source": "::\/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::82e0:1dff:fe6d:6419",
                        "metric": 512,
                        "valid": 1790,
                        "source": "2a00:6200:80:2b01:66d1:xxxxxxxx:xxxx\/64"
                }
        ],
        "dns-server": [

        ],
        "dns-search": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ]
        },
        "data": {

        }
}

root@Router:~# ip -6 a; ip -6 r; ip -6 ru
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::48dd:3fff:fea9:524d/64 scope link
       valid_lft forever preferred_lft forever
13: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd29:eae8:b670::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::66d1:a3ff:fe1d:49f3/64 scope link
       valid_lft forever preferred_lft forever
17: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a00:6200:80:2b01:66d1:xxxxxxx:xxxx/64 scope global dynamic
       valid_lft 2591995sec preferred_lft 604795sec
    inet6 fe80::66d1:a3ff:fe1d:49f5/64 scope link
       valid_lft forever preferred_lft forever
18: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::66d1:a3ff:fe1d:49f4/64 scope link
       valid_lft forever preferred_lft forever
19: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::66d1:a3ff:fe1d:49f3/64 scope link
       valid_lft forever preferred_lft forever
default from 2a00:6200:80:2b01::/64 via fe80::82e0:1dff:fe6d:6419 dev eth0.2  metric 512
2a00:6200:80:2b01::/64 dev eth0.2  metric 256
fd29:eae8:b670::/64 dev br-lan  metric 1024
unreachable fd29:eae8:b670::/48 dev lo  metric 2147483647  error -148
fe80::/64 dev eth0  metric 256
fe80::/64 dev br-lan  metric 256
fe80::/64 dev eth0.2  metric 256
fe80::/64 dev wlan0  metric 256
fe80::/64 dev wlan1  metric 256
unreachable default dev lo  metric -1  error -128
ff00::/8 dev eth0  metric 256
ff00::/8 dev br-lan  metric 256
ff00::/8 dev eth0.2  metric 256
ff00::/8 dev wlan0  metric 256
ff00::/8 dev wlan1  metric 256
unreachable default dev lo  metric -1  error -128
0:      from all lookup local
32766:  from all lookup main
4200000001:     from all iif lo lookup unspec 12
4200000013:     from all iif br-lan lookup unspec 12
4200000017:     from all iif eth0.2 lookup unspec 12
4200000017:     from all iif eth0.2 lookup unspec 12
root@Router:~# traceroute6 openwrt.org
traceroute to openwrt.org (2a03:b0c0:3:d0::1af1:1), 30 hops max, 64 byte packets
 1  *  *  *
 2  *  2a00:6200:80:2b01::1 (2a00:6200:80:2b01::1)  7.952 ms !N  7.210 ms !N

There's no IPv6-prefix and the IPv6-traffic seems blocked on the ISP-gateway.
Nothing really to do here other than disabling it, I suppose:

uci set network.wan6.disabled="1"
uci commit network
service network reload
ifdown wan6
wget -O /dev/null http://downloads.openwrt.org/
2 Likes