[Solved] Opkg: Unknown package 'tcpdump'

Hi, today is my first openwrt day. I managed to install it on a TP-Link Archer C7 AC1750 v1.1, by flashing the factory and systemupgrade binaries linked to from the page below:

I managed to have an ssh connection, and executed

opkg update
opkg install luci-ssl

which worked fine.
I then wanted to install tcpdump, but that failed:

root@router001:~# opkg install tcpdump
Unknown package 'tcpdump'.
Collected errors:
 * opkg_install_cmd: Cannot install package tcpdump.

I'm now following build instructions from the page below:
http://dvblog.soabit.com/building-custom-openwrt-packages-an-hopefully-complete-guide/ ,
building from the source branch that seems to correspond to the installed binary:
commit cf5e5204d976be00618f809b90c9c2156657903a (HEAD -> openwrt-19.07, origin/openwrt-19.07)

Following the instructions however led to warnings that are not mentioned on that page, such as:
WARNING: Makefile 'package/network/utils/iproute2/Makefile' has a dependency on 'libcap', which does not exist.

That didn't look too promising, but I proceeded anyway. The compilation is taking quite some time..

Is there an easier way to install the package?

root@router001:~# cat /etc/opkg/distfeeds.conf | sed 's|http://downloads.openwrt.org/releases/19.07.6/||'
src/gz openwrt_core targets/ath79/generic/packages
src/gz openwrt_kmods targets/ath79/generic/kmods/4.14.215-1-b84a5a29b1d5ae1dc33ccf9ba292ca1d
src/gz openwrt_base packages/mips_24kc/base
src/gz openwrt_freifunk packages/mips_24kc/freifunk
src/gz openwrt_luci packages/mips_24kc/luci
src/gz openwrt_packages packages/mips_24kc/packages
src/gz openwrt_routing packages/mips_24kc/routing
src/gz openwrt_telephony packages/mips_24kc/telephony

Post the output:

ubus call system board; opkg update; opkg install tcpdump
1 Like

You should be running the 19.07.6 release build. No need to build yourself.

opkg update stores the package index in RAM. It needs to be run again after a reboot (if you want to install more packages).

1 Like

Ah I see, yes that did it, thanks!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

Actually since it is a v1.1 you may need a special build because of the 5 GHz radio. I'm not sure what the present state of official builds is for that.

I saw mentioned somewhere that a driver was causing a bootloop because of a non-supported 5GHz chip, and that the 5GHz feature was removed as a workaround. Actually I only want to use it as an ethernet gateway to see what kind of information I'm leaking out to my ISP, so it's OK. I saw this page:
https://openwrt.org/docs/guide-user/firewall/misc/tcpdump_wireshark ,
hence the wish to install tcpdump.

Thanks! Sorry to be a noob, I didn't know I had to run opkg update again after a boot.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.