[Solved] OpenWrt + ISP router in Modem Mode - refuse to cooperate

Hi all,
first of all some disclosure - I am a noooob. I mean, I am all PC and stuff hardware/software guy, but I never really got into networks and linux-ish things, so there is a quite a big chance I am doing something wrong. But I am losing my hair in here so please, help me out.

So my case is:

  • Simple home network - Eth ->PC, external storage; WLAN -> laptop, tv, mobile phones.
  • ISP - UK Virgin Media with theirs shi**y SuperHub3.0 (let's call it SH3)
  • OpenWRT/LEDE/LuCI on Tp-Link Archer C7 V2 - "lede-ar71xx-optimized-archer-c7-v2-master" (when I bough C7 there was no customs for it, just found this one yesterday accidentally and thought I will give it a try, but maybe there is something missing in it? Here is a link to autor's page:
    [GCC 7.2 BUILD] Optimized TP-Link Archer C7 V2 AC1750 LEDE Firmware )

So, after a lots of problems with connectivity I ended up being able to write this post, but, my wired PC is only device working so far.
What I got is essentially some sort of passive switch.

  • SH3 is in Modem mode it own IP is 192.168.100.1

  • ArcherC7 settings

  • WAN:
    DHCP
    Mac override with SH3 Mac Address

  • LAN:
    Static: 192.168.1.1
    Subnet Mask: 255.255.255.0

So now, I can only access internet if my PC's settings are defaults so I am receiving IP essentially from ISP by SH3. And if I wish to change something in OpenWRT I got to change my PC's IP to 192.168.1.x range.
But still, ArcherC7 do not create any network, doesn't provide IP to clients etc. Any settings I am trying to change in LAN tab ends up with auto-revert due to fail connection test.

How can I fix this? Or what sort of information should I provide? I can make screenshoot, but if there is easier way of showing you my config please let me know with link to FAQ or Tutorial how to do that.

Not a expert here

But if dhcp on Lan is static I dont think router will provide ip addresses to connected devices

About how a modem only mode works where I could find information about it ? My question is if modem only just converts cable signal protocol to TCP ( not sure is the right protocol) from ISP to router how can I still connect to the modem through another IP address ?

Thank you for input. I tried to put it in DHCP, but it revert changes by itself. And all documentation states that modem and router (OWRT) has to be in different address group (they are now), WAN port needs to be DHCP not static and...there is nothing how to set up LAN settings. :frowning: But static is the only one accepted by software. I don't exactly know if I can try to force different configuration and what will happens if I will force something what I shouldn't have. That is whole purpose of this post. If I could get clear instruction to do that this way I will. :slight_smile:

Sorry to ear that !! Wasn’t able to find online manual @ virgin about superhub3. My only suggestion would be to repeat the modem only set up once more taking extra attention following the instructions ! Most of the time I end up with wrong configuration because not used to follow accurately instructions (fine prints, lines jumps, so on) more difficult if like me don’t know the meaning of the recipe

Can you set your ISP router to bridge mode?

There is no advanced configuration available. Many people have a problem with this device already. I can only click on simple switch:

Or just use it as a router with DHCP and Wi-Fi off.

BTW, I just learned how to use PuTTY, so here is my config:

  • root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5a:d538:c234::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option igmp_snooping '1'
        option ifname 'eth0.2 eth1.1'
        option ipaddr '190.168.2.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr '40:0D:10:73:98:33'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'
  • root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:01/0000:01:00.0'
        option htmode 'VHT80'
        option country 'GB'
        option log_level '2'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option htmode 'HT20'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'lan'
        option disabled '1'
  • root@OpenWrt:~# cat /etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option localservice '1'
        option nonwildcard '0'
        option noresolv '1'
        list server '127.0.0.1#5353'
        list server '/pool.ntp.org/8.8.8.8'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config domain

Why do you have MAC override with HH3?

1 Like

That should not be necessary, just try to reboot both the modem and the router, DOCSIS modems will only handle DHCP for devices connected to LAN ports for a relative short period after boot, if you manage to get the router to do its DCHP requests in that time window it should be getting an IP-address (using the same MAC on both your router and the modem is a bit unclean and depending on what happens with the MAC might cause subtle glitches)

1 Like

I also see you set the HH3 in modem mode. That looks like bridge mode. If that's the case, you should set your OpenWrt WAN to PPPoE. Or where do you have your DSL credentials now?

I assume the user is in Virgins DOCSIS network, so I believe it to be rather unlikely that PPPoE encapsulation will be used there...

3 Likes

Exactly, PPPoE is not applicable here. I used to configure many simple network like this with different provider in another country (also not PPPoE) and cloning mac was necessary to make it work. So I just go with what i know :wink: I'll get rid of it and try to reboot both devices.

Edit:
After deleting Mac address cloning I am no longer able to connect to internet at all. I mean, with Mac clone my PC worked as connected directly to the modem, but now Archer is a hard wall. I tried reboot them in sequence but it didn't help. Will try few more times.
Mbut please have a look on this now. My PC and phone got IP from Archer, but Archer itself is not connected to modem.

1 Like
  • Was Mac cloning required at all if you connect via the SH3 router directly?
  • Did you try to setup WAN6 interface and see if it will get anything?
  • For the sake of trial, if you connect SH3 to OpenWrt LAN, all devices are working?
1 Like

Hiya, just weighing in here as I'm on exactly the same ISP connection: Virgin Media SH3 in modem mode on 200/10 service with a WRT32X running OpenWrt 18.06.2

You do not need to clone the SH3's MAC address, and it'll likely break the bridging in the SH3 if you do so. Just leave your C7 WAN interface with its default MAC address and set it to DHCP. It'll pick up the one IP address you're allocated for that connection and NAT between your LAN and WAN. You may have to power cycle your SH3 as you've been mucking around with MAC addresses.

I notice you've also changed your LAN address from the OpenWrt default of 192.168.1.1 to 192.168.2.1. While this is a perfect acceptable address to use I've found OpenWrt doesn't handle change like this very gracefully. Unless you really know what you're doing and can update all the other subsystems on the router to reflect this change I'd strongly advise leaving it set to 192.168.1.1

For that matter, with all the changes you've made, I'd be tempted to reinstall OpenWrt. It should "just work" as soon as it boots up connected to the SH3 in modem mode (you'll need to configure the wifi though, obviously)

The C7v2 is now fully mainstream. Use the 18.06.2 release build. http://downloads.openwrt.org/releases/18.06.2/targets/ar71xx/generic/openwrt-18.06.2-ar71xx-generic-archer-c7-v2-squashfs-sysupgrade.bin I suggest you remove the unknown third-party build completely by upgrading to this official build-- also do not try to save the settings.

Other than turning on WiFi, you should not need to change anything from the default settings. By default the LAN has a DHCP server so PCs connected to the LAN should automatically configure to 192.168.1.X.

Cloning of MAC addresses is only if the ISP has registered the MAC address of your old router in its system and refuses to serve the new router. Then you would set the new router's MAC to match the one of the old router. The old router is shut down, unplugged, and on the shelf or in the bin at that point. You cannot have two devices active in the network with the same MAC address. (If you are in that situation it is best to call the ISP and tell them to release your old MAC address and let you use the new one. Cloning the address should be a last resort.)

What is the DHCP address the OpenWrt router receives from the ISP modem/router? This will be "IPv4 Upstream" (and possibly "IPv6 Upstream") on the main status page.

1 Like

I am not aware of that. If you believe there is an issue there, you should report it as a bug.

1 Like

Yeah, I would do but I'm not about to tear my network to pieces to provide diagnostics, I'm afraid, and I know how frustrating it is for support to receive a bug report with nothing but unsupported comment from the user.

Basically, when I first started using OpenWrt my home LAN was all configured for 10.0.0.0/8 from the old router I was using. I didn't want to reconfigure my whole network so set the OpenWrt box to have 10.0.0.1 for it's LAN NIC and hand out addresses from that range for DHCP. I had all manner of weirdness while trying to run like this, all resolved by returning the router to 192.168.1.0/24 ¯\_(ツ)_/¯

Just a quick one, thank you for all replies. I am night shift worker. Let me get back to you tomorrow morning when I reconfigure my router according to yours advices.

2 Likes

I can imagine you did have issues, telling a small router to be ready to route 4 million IP addresses. You could have made a smaller subnet like 10.0.0.0/24.

I agree that the OP may need to simply keep OpenWrt ate defaults, and reboot the modem - before trying to make major changes to the configurations.

2 Likes

I too agree that it'd be a good time to install the default 18.06.02 build, tell it to NOT keep settings, so you wind up with a default out of the box experience, and then do "the dance" with the modem:

  1. Turn off Modem and Router
  2. Unplug Router from Modem (ethernet cable)
  3. Wait at least 10 seconds for capacitors to discharge etc
  4. Turn on modem and wait about a minute for it to sync to the service
  5. Turn on router and wait about 30 seconds for it to get booted up enough that the switch is configured and MAC addresses don't leak onto the WAN
  6. Plug router ethernet into modem at this point.

All should work fine at this point. The reason for "the dance" is that these consumer devices often have a switch chip that when it first boots up by default floods packets to all ports. The modem will usually lock onto the first MAC address it hears as the only one it will respond to. If you have the modem in its brand new rebooted state, and it's waiting for a MAC, and then you boot up the consumer router, the first MAC it hears will be a random variable. But if you let the switch get configured first, then it's sure to hear the MAC of the WAN side of the router as its first packet. You can also boot up the router first... and then boot the modem that should work.

3 Likes

Doh! Dunno why on earth I typed that...

It should, of course, have been 10.0.0.0/24

I'll hand in my CCNA at the door on the way out :crazy_face:

1 Like