[Solved] OpenVPN version issues

I am attempting to configure OpenVPN on my WRT32x flashed router. I use the following procedure:

opkg update
opkg install openvpn-openssl
opkg install ip-full
opkg install luci-app-openvpn

This version does NOT have an option to upload an OVPN file so after a bit of googling I found the following procedure:

Change distribution feed to:

src/gz openwrt_luci http://downloads.openwrt.org/snapshots/packages/arm_cortex-a9_vfpv3/luci/

Remove luci-app-openvpn
then install snapshot version

This works fine and now I get option to 'OVPN configuration file upload' but get error (also if trying to edit exisiting OpenVPN instances) :

404 Not Found
Sorry, the object you requested was not found.

Unable to dispatch: /cgi-bin/luci/admin/vpn/openvpn/basic/sample_server

Note: previous version without option to upload allows editing.

I have read something about snapshots being unreliable. The versions of luci-app-openvpn versions:

original 19.282.28671
snapshot 19.284.27115

Is there likely to be another dependency that needs reinstalling to give compatibility?

fwiw, have you tried OpenWrt 19.07-snapshots if you wish to use the .ovpn upload function?
Works fine for me with a couple of low-end routers.

Otherwise, review the v1.1 PDF mentioned at bottom of the page if you wish to revert to OpenWrt 18 stable and manually upload .ovpn files with scp:

Cheers bill888

What is involved in 19.-7-snapshot. Do I simply download the luci-app-openvpn-xxxxx.ipk file and run it from the command line (after removing the older version first) or are there more files to download.


First of all determine what version of OpenWrt is installed (18.06.4 stable, or Davidc502 build?) and do you know the history of how it was installed because the WRT32X has dual firmware.

You are considering replacing the version of OpenWrt already installed with OpenWrt 19.07-snapshot using squashfs-sysupgrade.bin file.
(19.07-snapshot includes LuCI btw.)

You can normally install the squashfs-sysupgrade.bin using LuCI, but as your router has dual flash, you may wish to choose different action of installing it. See 'Upgrading OpenWrt' section:

Someone with far more knowledge of WRT32X may be able to help with upgrade advice. I can't comment on how well 19.07-snapshot runs on WRT32x.

If you are not confident and don't wish to risk bricking your router, I would perhaps suggest installing .ovpn file as described in v1.1 PDF guide mentioned in previous post if you have a Windows computer. You can always upgrade to 19.07-snapshot later.

Good luck.

Snapshots (from master) are generally "reliable". However, the packages need to be installed within a day of flashing, as they are different for every kernel build (which happens just about every day). Snapshots generally don't include LuCI, so that has to be added (using opkg) if you want it.

The 19.07 snapshots are reasonably stable and, from what I have read, have LuCI preinstalled. However, the 19.07 branch is over 1000 commits behind master at this point, and release candidates appear to be several weeks out, so I wouldn't hold my breath for that.

I'd go with

as the most straightforward, near-zero-risk approach.

As pointed out, the WRT32X is a dual-firmware device, which makes "roll-back" to the previously installed version and its config very easy, if you did want to try flashing a snapshot. As you've got one previous version available to you, don't flash twice if you want to roll back to your current version.

Thanks for everyones advice. Ended up upgrading to 19.07 and the problem went away.

Will now have a little play tweaking the VPN as I am not entirely sure the OVPN file that I downloaded from my VPN supplier is 100% compliant (IPVanish) but can be modified. The contract is up soon might look at another supplier

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.