[SOLVED] New ISP and Linksys A/B dual boot won't boot OpenWRT

My Linksys EA7300 v2, which previously worked with a DSL modem with the following settings, now will not boot with the new Cable ISP modem.
DSL <---------> EA7300
EA7300 Workstation <--->

         New WAN

Cable Modem <-/-> EA7300
? Should have default DHCP WAN settings

My DSL was ancient (4.5Mbps down) and I switched to Cable w/ a refurbished Motorola MB7240.

In stark contrast to my old DSL modem, the new Cable modem has no configurable settings. I started with a fresh 21.02.1 OpenWRT install after flashing the OEM firmware over itself.

I think it flashed but the router appears to attempt 3 boot cycles before falling back and successfully booting the OEM firmware.
My forum search found this post regarding failed OpenWRT installs in the same device IP range 10.xxx.xxx.xxx.

yes i put these three lines in /etc/rc.local .Previously it used to revert back to orginal fw.I am not sure what it does but this can be done only after installing openwrt. So if it got installed ,then main part is already done. You will have to manually assign ip address if your main router is not in 192 range. Mine was 10.1 range and so manually had to add it to get LUCI webpages...and also to install packages.

The Cable modem interface says "IP": but the MAC does not match my EA7300. I see nothing in the Linksys OEM user interface as to what WAN DHCP address was assigned. The "Trouble Shooting" interface says Internet Address which reverse DNS look up says belongs to Spectrum

I previously has set /etc/rc.local to

/rom/sbin/mtd unlock s_env
/rom/sbin/mtd erase s_env
exit 0

Is this a known issue? Short of buying a Modem/Router combo and subneting to the EA7300, is there a work around? I think I can get back into OpenWRT using the old DSL modem.


This text will be hidden

What do you mean "will not boot" -- are you saying that the device cannot even boot up (i.e. it is not completing the general booting process), or are you having difficulty getting an IP address on the WAN and thus internet connectivity isn't working?

In most circumstances, cable modem connections use DHCP. You may have to reboot your modem (possibly several times) for it to "learn" the MAC address of the router. Also, many cable ISPs require that you register the modem's MAC address with their system. Have you done this?

It sounds like the device is booting -- when you connect to the device, is it running OpenWrt or the Linksys firmware? Or are you unable to connect to it?

This is entirely expected, at least for US based cable ISPs. This is how DOCSIS works -- all settings (save for a few trivial ones like the LEDs on the device) are managed by the ISP.

I'm not sure why you are looking for this -- OpenWrt's default configuration has the router's LAN at the IP address

Are you talking about the status page of the modem itself? or something else?
The MAC that you see there is probably for the modem itself (which is usually necessary for the ISP to have registered for the modem to get service in the first place). You can verify this - there should be a sticker or info panel somewhere on the modem itself and it will indicate the MAC of the modem -- does it match what you are seeing on the interface?

So you're booting to the Linksys firmware? If so, you should ask Linksys support. If you can boot OpenWrt, we can help.

Are you a spectrum subscriber? If so, that sounds like you're getting a proper IP and that your network should function. Again, if you're running Linksys firmware, you'll have to ask them about why you're having trouble. We can help with OpenWrt issues.

Side note: it is usually not a good idea to publish your complete public IP address.

In OpenWrt? or in the Linksys firmware? Where did you see instructions to do this?

Is what a known issue?

Not sure what "workaround" you are looking for. You shouldn't need a combo unit.

Why would you want to use that old device?

On cold start, the EA 7300 front panel light blinks and then pauses, blinks some more then pauses, then blinks again, pauses and blinks and the Linksys OEM interface comes up.

Yes is activated and I have internet w/ the OEM firmware.

ssh gives the message port 22 is closed and, once the front panel light is continuous, http goes to the Linksys interface. The A/B, dual boot nature makes this more challenging.

I understand, my old cisco dsl modem assigned 10.x address to the WAN side of the router. I have no idea what IP address the Cable modem is assigning.


In OpenWRT as guided by the device page:

If you are not familiar with this series of Linksys devices they have 2 copies of linksys firmware which the device page refers to a A and B. The device will make 3 attempts to boot OpenWRT and if it fails it falls back to Linksys OEM. I think it attempts 3 times to boot OpenWRT, each attempt fails and, on the 4th attempt, it falls back to Linksys.

It used to work with the old DSL modem with firmware I built my self - I actually submitted the patch to add the device. The only substantial change was the modem and updating to 21.02.1. I don't think its the firmware, others are running it and I confirmed the sha256sum.

The Linksys interface does have a Connectivity Page with "Internet" tab. It tells me my connection type is "Automatic"; IPV6 is automatic and enabled. It gives a DUID which is new a term for to me. I previously kept everything on the LAN side in IPV4.

OpenWRT starting to boot and failing 3x and then falling back to OEM firmware, which runs without issue. I do have a usb serial connector, I suppose I'll open the case if there is not an known fix. I try not to pry apart plastic clips until after I've exhausted every other option.

I'd recommend trying to install OpenWrt again from the Linksys firmware upgrade menu, assuming that was the method you used. Be sure to use the factory image for installation.

As for the rest...

This sounds like there is an issue with the OpenWrt installation, so at least it is not bricked.

All of this makes sense if you're currently in the Linksys firmware.

One of two things were happening with your DSL modem: either it was actually operating as a router and was giving you a NAT'd address, or you were getting that RFC1918 address from your ISP (a form of CG-NAT). Unless you are working behind a router that you control, you will not have any control over the WAN IP assignments that occur via DHCP or PPPoE -- that is the responsibility of the upstream router and servers on the ISP side (exception: if you have a static IP from your ISP).

Most router firmware will have some way of telling you what the WAN IP address is. I don't know where you will find it with the Linksys firmware, but OpenWrt will show it to you in 2 places (status: IPv4 and/or IPv6 upstream; network > interfaces > wan and wan6). You can always google "what's my ip" and you'll get an answer about your apparent public IP (which should be the same as your WAN IP in the case of most major US cable ISPs).

Yeah, I am familiar with the dual boot partition of these devices, but I didn't understand that from your initial post that it was failing to boot into OpenWrt (an actual boot failure vs a networking issue) and that it was doing the fail-over to the Linksys firmware (which boots and functions properly). The initial post was a bit confusing, but your responses have cleared some of that up.

This is likely the "Device Unique ID" -- it is just another identifier that can be used to uniquely identify any piece of hardware.

I don't know about the status of OpenWrt on this device, but as I mentioned earlier, try reflashing to see what happens. As far as opening the case -- if you're looking for a generally functional router, it sounds like it does work on the Linksys firmware, and thus not worth opening since it does work as a router. If you want OpenWrt and are willing to troubleshoot, gaining access to the serial port would certainly give some clues as to what is happening in the boot process.


Based on this:

  1. Power down the modem
  2. Flash OEM Linksys firmware over itself wait for reboot
  3. Flash OpenWRT
  4. When the OpenWRT install starts to reboot, power up the modem.

Some more thoughts on this.

NetBSD has a dhcpcd setting where you tell the boot process not to wait for a dhcp address.
If OpenWRT waits for the assignment of a dhcp address and the modem window that negotiates the IP assignment is closed, it won't get a dhcp address. Could this cause a new install to fail to boot?

I'm wondering if there is a setting on OpenWRT not to wait for the WAN dhcp address. It would be nice to restart the modem and just click for DHCP renewal.

Unless there is something specific and unique about the way that OpenWrt runs on that hardware, this is not an issue. You can always boot an OpenWrt device without an upstream (WAN) DHCP lease. I do it all the time with one of my experimental devices that may or may not have any connection upstream. If there is something happening on that hardware, it would constitute a bug.

Testing this should be fairly simple -- if you have a spare router, you can use that as a DHCP server to the WAN DHCP client of the one in question. Just make sure the subnets don't overlap.

If you can demonstrate a reproducible behavior where the EA7300 boots fine when the WAN gets a DHCP lease immediately upon boot up, but then fails to boot properly if the WAN isn't connected (and/or if it is connected physically but without a DHCP server upstream), you would have identified a bug.

Good to know. It actually would not boot to OpenWRT with the WAN RJ-45 disconnected but I'm hesitant to retest. I changed my email and I need to focus on updating my financial accounts, open source forums and contacts. I'm willing to retest after all that is taken care of. There were a number of other users - another user with the same behavior would be strong evidence of a bug and not just a Spectrum DHCP server quirk.

Found more of the same:




This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.