Can OpenWrt 19.07.3 Router be used with Spectrum Cable modem?

Dear Colleagues:

  1. I loaded OpenWrt 19.07.3 into a TP-Link Archer C20 V4 Router. Everything worked fine as a client device on my existing HAN (Home Area Network) with Gateway address at 192.168.1.1 to Spectrum Cable service.

  2. The WAN port address on the router that came with the Cable Modem was 24.193.167.86.

  3. After connected to the Cable Modem, the LAN side of the OpenWrt Router operations seemed to remain normal. However, the connection to the Modem could not be established. Accessing through the LuCI, its "Network - IPv4 Upstream" information panel was missing, followed by "Active connections ?", as if the cable to the Modem was disconnected. Although, the status LEDs on the associated ports were flashing, hinting some handshaking was going on attempting to make the connection.

  4. Could anyone kindly clarify what was happening and whether there is any limitation on the IP address range that OpenWrt would accept on its WAN port? What could I do to cross this hurdle?

Thanks a lot,

Abe (2020-07-31 09:52)

Try rebooting both the OpenWrt router and the cable modem. In the DOCSIS provisioning method the modem is supposed to only consider DHCP clients that show up in a relative short window after boot-up. So often the sybchronized reboot approach will make sure that your router will send a DHCP request up its WAN port in a period when the modem is willing to entertain the idea to add a new MAC address/device. Not guaranteed to be your issue, but IMHO worth trying.

2 Likes

If a simple reboot doesn't work, next try turning the cable modem off and leave it off for about 30 minutes for the cable system to forget the MAC address of the old router.

2 Likes

moeller0 & mk24:

Thank you two for the excellent insight and instructions.

To avoid disrupting ongoing daily activities, I shall try this procedure out late this evening and then report.

Regards,

Abe (2020-07-31 12:22 EDT)

mk24 & moelle0:

  1. It worked!

  2. To minimize the possibility of distraction, I did the more conservative approach suggested by mk24. I powered down both Cable Modem and its accompanying Router for 30 minutes upon inserting the OpenWrt 19.07.3 Router in between. After power up, everything on my HAN worked as before.

  1. Now that I have an OpenWrt 19.07.3 Router in a working network router chain, my idea of making use of its 240/4 netblock support for expanding the assignable public IPv4 address pool is realized. I am in the process of documenting this scheme. In due time, I will post our experiment for colleagues on this Forum to replicate.

Thanks again,

Abe (2020-08-01 08:00 EDT)