[Solved] NETGEAR RBS50 snapshot build, missing lan ports bug?

I freshed the RBS50 with snapshot build. It only shows eth0, and eth1 on the interface.

The device has 4 ports ☐ ☐ ☐ ☐. The left port assigns to wan, and other 3 ports assign as eth1.

Is any patch or fix for this mode?

Any help to fix the missing ports are welcome.

More than likely, the ports are actually connected to a hardware switch. If that's the case, you'd see the CPU connection as eth0 and/or eth1, and the rest would be handled by the switch.

Let's see your /etc/config/network file -- that will help us understand what might be happening.

the /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd4e:6d44:e0f9::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 0'

The config file confirms my assertion.

The WAN port is directly connected to the CPU at eth1.
The LAN ports all run through the switch, connected to the CPU at eth0.

user error :blush: , I thought it is on DSA.

the ports show under [swtich].

thank you @psherman !!!

you're welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.