[Solved] Netgear EX6150v2 stopped working after installing OpenWrt

Today I installed the latest Openwrt firmware on my Netgear device


Now wifi won't start at all. How do I rollback to the previous OEM firmware


Install via TFTP:
Connect to the devices serial. Hit Enter-Key in bootloader to stop
autobooting. Command "fw_recovery" will start a tftp server, waiting for
a DNI image to be pushed.
SERIAL: Header next to QCA8072 chip.
        VCC, TX, RX, GND (Square hole is VCC)
        WARNING: The serial port needs a TTL/RS-232 v3.3 level converter!
        The Serial setting is 115200-8-N-1.

Thanks. I am a noob when it comes to Hardware. I just want to ask, just in case is there any other easier solution for me?

Yes, buy another router.

Of course.

WAIT A MINUTE.. YOU DID ENABLE WIFI right? :face_vomiting:


I think as a new user you might have limits on how many posts / links you can post etc ( you can possibly edit your post above with newer comments if there are issues ). But... as my earlier reply was a little pragmatic.

There is medium term hope that your issues will be fixed soon in a development release ( assuming there is an underlying problem )...

What would help, is if you are able to learn some basic ssh skills if needed... then ssh or putty into the router and paste the output of a few commands ( you'll likely need pastebin or similar ).

logread | tail -n 50
cat /proc/mtd
cat /etc/config/wireless

With this info, it's likely underlying issues might be fixed sooner... so you'd have the option of flashing a SNAPSHOT and installing luci on top. Even if they are not fixed, a confirmed issue can be noted on the wiki saving others from your hassle.

( mandatory condescending speel re: user fundamentals - sorry )
That said... you should always read the HOW TO REVERT instructions... ask on the forum if there are none... as is the case here ( commit info only )... before flashing or better yet buying.

Saves you selling the thing.


Thanks. You were completely right.

It was so strange that wifi is disabled by default in Openwrt. Also for some reason, my repeater flashed orange beep several times which made me think it's fried.

But I was able to connect to it using Ethernet (both SSH and HTTP UI). Now I have enabled Wifi and everything is working finally.

Thanks. Getting a new router would have been a big hassle because of coronavirus lockdown these days.

WoooHoooo!!! :bat:

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.