[SOLVED] MacOS recognises SAMBA disk, but not Windows

Failed to stat all but /dev/sda1 which is listed as ext4.

Ok I’ll do this

Do you have a USB stick for extroot connected?

i think you may have just formatted the 1st partition on your HDD using openWRT, this 1st partition is usally a few hundred MB and contains boot code and bios information for Windows, and then there can be a "Recovery Partition" from a manufacturer before your actual "Data" partition with windows and your files on it :slight_smile:

Ok thanks for your help, I have formatted the drive as a 500GB ext4, linked it in LuCI, it was mounted, but now Windows cannot connect to it. Hang on let me check permissions!

Chmod 777 it but still Windows comes up with an error when trying to find it.

Under mount points it says (not present) after the UUID

It just doesn’t work at all now. Windows won’t connect to it.

Windows network diagnostics says the remote device ( is not set up to accept connections on port “The File and printer sharing (SMB)”

I will have to give up. I have never got Samba working successfully. Why did it work earlier, but not now?

Share discovery is done via the "wsdd2" package for windows clients, "avahi-dbus-daemon" for linux/macos clients and "ksmbd-avahi-service" if you use ksmbd instead of samba for linux/macos clients. There is no need to manually mount via ip.

No idea, the samba4 and ksmbd package work out of the box in writable guest mode, so if a compatible/writable filesystem is used (ext4 + chmod 777 on the share-root) it should just work.

PS: The discovery services are not installed by default for size and security reasons, since technically they are not needed. So yes there is room for improvement via documentation, anything else should work after the share is setup.

That only works if a discovery service is running on the router, since the sharename needs to-be announced. So actually you need to use \\192.xxx.x.x\sharename.

This is what I had to add to access on windows

I posed on YT

"i have managed to get samba working, using your guide but with some additional steps needed, i had to add "nas:*:1000:65534:nas:/var:/bin/false" to ect/passwd & "nas -a newuser
(My shared folder is called nas so replace "nas" with your shared folder name)

" to overlay/upper/ect/samba/smbpasswd before windows 10 would connect to it (it would say Cant find find drive before i edited those files) & also had to enable the option "Force Root" to make the drive writable, so i can now map the drive using "Map Network Drive"

The drive still wont show up in the "Network" Folder on windows automatically though, i created samba.service in /overlay/upper/ect/avahi/services tries with the port set at 139, also tried port 445 (the new samba port) but it didnt work either, the drive still wont show up in network folder, This is a picture of my samba.service file

I do not understand this.

Please do not open multiple topics for the same issue.
Please focus now on your second topic Cannot connect or find Samba disk

  • avahi is linux/macos only not Windows
  • samba4 don't need the "old" avahi service files (the smbd service will directly communicate with the avahi daemon)
  • you need wsdd2 for windows

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.