Cannot connect or find Samba disk

Ok, so, I got Samba working earlier but on the wrong partition, only 180MB. So I reformatted the disk in ext4 using a third party partition manager, and tried again. Disk is mounted, but I cannot connect to it. At first I got an error, and Windows diagnostics said the router was not set up for samba. But now it just endlessly attempts to connect to the disk with no resolution. I am thinking of giving up on samba altogether, as I first started trying to get it working months ago and have never managed to succeed.

Any ideas or help would be appreciated. I’m getting the error message that the router is refusing the connection again. I haven’t changed any firewall settings.

I’ve reformatted the drive using the router instead of a PC. It just won’t find the disk or connect to the router as a server. It was working before I formatted the disk using a computer, now, not working at all. It’s a mystery.

MacOS also now cannot find the disk and OpenWRT is not listed under Network. It seems Samba has stopped working. What should I do? I am giving up until tomorrow. This is very dispiriting, it was at least working earlier although I had partitioned the drive incorrectly, now, it’s as if samba has just broken.

Setting up NAS on this router has been such a difficult and impossible task with no success after so many attempts and so many issues, I think I am just going to buy a consumer NAS server, plug and play!

Which samba server did you use?
Samba36, samba4 or cifsd?

I've just yesterday hit the same issue with samba36. Samba4 wouldn't fit the flash, so installed cifsd, and it worked instantly.

Client's a PC though.

Or you can simply use SFTP:

One step at a time...

First plug the drive to the router, mount it, and check that it is mounted and where.

There is no need to reformat the drive over and over again.

1 Like

Ok drive is mounted fine and it's in /dev/sda1 and /mnt/sda1 and linked via LuCI as a network share. But it's not appearing in Windows or MacOS.

Ok I installed both those packages and tried to connect to my router using Cyberduck, connection failed. It also has not made the disk visible in the network or allowed connection to it.

CIFS looks too complicated for me, I don't want to try it and mess up the router. I think I am going to give up and buy a NAS drive and just plug it in.

Shall I try removing Samba and reinstalling it?

It's just as simple as samba36, one dialog window openwrt.

The guide says that CIFS does not work with LUCI? It seems a lot of the documentation is out of date. Do I have to uninstall Samba to install CIFS? How do I install CIFS, if the guide is out of date?

Edit: Through LUCI I installed cifsd (called Samba4-client). Was that it? It hasn't made any difference, still can't find the drive.

  • uninstall any cifs/samba/ksmbd package.
  • than just install the luci-app-samba4 and wsdd2 package

Than just config your share and leave everything at defaults for now. If you can see the share in windows, but not write to it, enable the Force Root option on the share.

PS: Atm i only recommend ksmbd as a samba drop-in replacement, if you run snapshot based builds/firmeware.

Ok did this. OpenWrt now appears under Network, however, I cannot access it by clicking on it and I still cannot access the drive at \192.168.x.x\NAS

Error: 0x80070035
The network path was not found.

Network diagnostics: the remote device or resource won’t accept the connection. The device or resource (OpenWrt) is not set up to accept connections on port “The File and printer sharing (SMB)”.

Also to note: since reinstall the Samba Template is now blank.

it's \\192.x.x.x\something for starters.

The drive should have a mount point, even if the drive's not mounted, you should be able to access or see it, yet as an empty share.

I think the Error: 0x80070035 is what I had when I ran samba36.

The "samba edit template" entry in luci? Thats odd and should not happen, you can try copy&paste the template entries from here.

PS: What is the system log showing? (search for daemon.err smbd entries)

I am not sure how to check or find the system log.

Edit: nevermind found it, will update with edit in a mo.

Ok cannot find any daemon.err smbd entries, did notice it said samba4 was in a crash loop at 2.30pm. I’ve tried copy pasting into the samba template but I cannot save and apply, it says, permission denied. The template I pasted in does not save. @Andy2244

Than something is very broken, either forget about samba if anything else works or reinstall a fresh firmware, without keeping the settings.

PS: Btw whats your router? Just to make sure you have enough space available for packages?