[SOLVED] Issues with Meraki MX60 and MX60W Images

Hello all,

Using 17.01.0, 17.01.1, 17.01.2, 17.01.3 and 17.01.4.

There is a severe problem with the Meraki MX60 and MX60W images.

  • The BIN files do not properly setup the WAN and Switch, the device makes DHCP requests on all ports with a VLAN tag of 2
  • There are currently two workarounds to proceed past this roadblock, here:
    Please Help with meraki mx60w, accidentally the whole thing - #12 by sealghost
    and here: [SOLVED] No IP or LuCI on Meraki MX60W - #13 by lleachii
  • It appears swconfig is missing from the BIN files, and other relevant software to setup the LAN and WAN
  • The BIN files for the MX60W do not include the wireless driver
  • This means that using these BIN files as the recovery image has the same effect
  • On the MX60W, you can only flash the MX60 sysupgrade
  • Using the MX60W file produces an error to use the generic image for the device, the MX60W TAR files don't work
  • This means that WiFi is not pre-configured by default on the MX60W
  • No documentation notes this configuration/issue in the recovery images and MX60W sysupgrade files.

Can these issues be addressed before the next release?

There's also an issue with the documentation...the pages for the MX60 and MX60W link to instructions off-site. The U-Boot environment changes are incomplete...holding the button on boot seems to load the following file noted in the environment variables:


This could be changed to something better (i.e. erasing all partitions on the NAND except 0/board-config and 1/recovery, read-only, etc. OR to TFTP buck.bin).

From what I know (I don't have any MX60/MX60W) the switch is just missing the swconfig package. Chris Blake made a fix to include the package back in March/April 2017. The patch has been accepted and is in the master-branch, but not to the lede-17.01.x:

(This patch also adds kmod-ath9k and wpad-mini. This will make it possible to use the wifi with the initramfs images too).

I don't think there's any ETA for backporting the "apm821xx: Add default packages to NAND target". It looks like everyone is waiting for 18.0x to be released.

1 Like

Now I have another issue...I haven't tested the BIN yet; but I've used the TAR and upgraded to Snapshot.

Powered by LuCI Master (git-18.101.21196-d488681) / OpenWrt SNAPSHOT r6687-d13c7ac

Now, my LAN ports only negoiate at 100 Mbps. I cannot get Gigabit Ethernet.



Hey @lleachii, sorry to hear you are having issues.

I just tested r6646 on my MX60 and am unable to reproduce the LAN port issue you are seeing.


In my screenshot, LAN1 is actually plugged into a 100mb device, so that is expected.

Just to confirm, did you do a factory reset after flashing r6687? I recommend trying that to start. We also recently had a fix merged into master at https://github.com/openwrt/openwrt/commit/c61c709f4e3f4331716d6e5624f7678d03b5d80c to fix cases where the switch would not work after the change to the 4.14 kernel.

I did perform a factory reset. I did that immediately after seeing I was only connected at Fast Ethernet speed (100 Mbps).

Ah, the master branch switched to the new metadata image checks with this commit:

The new metadata image checks was developed by Felix to unify the myriad of different board and image detection scripts all across the tree... and as you can see the commit removes a lot of custom cruft.

Now, sysupgrade will expect all .tar images to have the prober metadata. However it should also tell you that you can force flashing older images via the "-F" switch. See:

"Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware"

I noticed that after the factory reset, I had 1 Gbps connection, but no Internet!!!

I also didn't have any Firewall Configs! I restored the backup config, and its back at 100 Mbps.


I'll try this...

UPDATE: using -F worked...I think that Snapshot allows you to setup your firewall from scratch (since it is a security appliance). It would be nice to have some more information on the changes made in the firmware between v17 and v 18.

Thanks again for the help. I flashed an earlier LEDE image and got the LuCI gui.

1 Like

Has anyone used the 18.06 BIN file yet?

I'm not sure that LuCI works; but swconfig does work properly.

So with a working LAN and WAN, I used SSH to login, wget the TAR file and flash the router. I should note, when I attempted to install LuCI, it told me the current version was already installed. Perhaps I didn't wait long enough for the config files to build before I tried SSH.

Since I expanded the recovery, and it was my production router, I did not want to "play" with the router too long with only the BIN loaded in memory.

I have another MX60W in the post, when it arrives, I will test again.


Any news on your MX60W with 18.06?
I have an MX60W to flash and I really do not what I should do... 18.06 or 17.01.4?

Issues with the image have been fixed; and the various workarounds always allowed you to use the router with OpenWrt. I've made numerous posts since this thread, this one likely most relevant to a working image:

  • LAN issue was never present in the MX60 image
  • Therefore, the 17.01.4 MX60 image works (you will have to install WiFi driver yourself after flashing)
  • The current 18.06-SNAPSHOT for MX60 works (there are no separate MX60W images any longer, WiFi is pre-installed)
  • Both BIN and TAR files work

I'm currently running OpenWrt 18.06-SNAPSHOT r7013-f18f08d.

  • I have not worked on the Reset button loading recovery, but this does not hinder flash and using the MX60W

Hope this helps.

It helps a lot,
can you provide the bin and tar download links for your tested 18.06-SNAPSHOT r7013-f18f08d. ?

Since SNAPSHOT has updated since I downloaded r7013-f18f08d, the best I can do is give you the link to the SNAPSHOT site for our device:


As of this post, today's SNAPSHOT is: r7025-6cf00dc.

Thanks, I'm trying to flash my MX60W now.
Is the UART a TTL 3.3V? will a PL2303TA USB-UART cable make it?

Are these booting/flashing instructions still working?


I would assume so...mine is Serial, so it doesn't need drivers...

Begin following the instructions at BOOTING. As you already know, the MX60(W) is now supported, so an image exists on the OpenWrt download site.

I will not say yay or nay to those, please understand the commands you are entering. With that said, there are no changes.

All lines can be entered verbatim, except the one noted in the instrcutions:

dd if=/dev/ubi0_XX of=/tmp/board-config.img

Verify the UBI partition of board-config, you must ensure this partition is backed up per the instructions. If not, you will not get the device's MAC address upon booting OpenWrt.


ubimkvol /dev/ubi0 -s 5MiB -N recovery

MAKE THE RECOVERY AT LEAST 9MiB, 5MiB will not work with 18.06! I've made mine 10MiB.

Finally, how do I boot into U-Boot console on the MX60(W)?
just boot the unit and hit Enter several times at the terminal emulator?
Thanks for your help.

I'm not sure I understand...do you have your serial cable properly connected and see output on the screen?

There's a prompt on the screen to interrupt the U-boot within 2 seconds.

If you fail to do so, the Kernel loads.

didn't receive the cable yet, Then I connect the cable, boot the unit and I have 2 secs to hit Enter at the console and to stop the normal boot. Thanks.

MX60W flashed and working so far. Thanks for your help.
Is there any doc/video showing how to "configure" OpenWRT as a home router? planning to use it with WebPass. Thanks again.

The wiki offers plenty of information: https://openwrt.org/docs/start