[Solved] ISP Provided CDN Cache not working [Solved]

My ISP provide caching through a local dns server (Steam, Epic Games, etc). While Using the stock firmware of my archer c6 v3.20 cache works perfectly and even DNS default server gets recognized ( ns1.lc.****.com ). But on OpenWRT it doesn't show-up the default server says ( Unknown ) even setting up the dns in windows won't work either is there any way to fix this problem It'll be great for me as I like OpenWRT over the tp-link stock os...

There isn't anything in the default config of OpenWrt that would block your ISP caching from working.

  • Was the router previously running a customized firmware from the ISP, or was it the TP-Link firmware that could be downloaded from the TP-Link website?
  • Did you have any special configurations previously set with the vendor firmware?

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

DNS servers must be specified by IP address because whey must be reached without querying guess what - DNS servers.

Brother I'm extreamly sorry I re-installed OpenWRT and It seems to be fixed can it be cause by packages before re-installing I was using
( irqbalance,UDPspeeder,miniupnpd-nftables )
Rn no 3rd-party packages are downloaded and the problem is no more present

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        list dhcp_option '6,172.16.172.10,172.16.172.14'
        list dns '2001:4860:4860::8888'
        list dns '2001:4860:4860::8844'
        option ndp 'relay'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

Can I ask for other topics in this thread or do I have to open an another thread ??

One topic per thread, please. This keeps things tidy and makes the forum more usable.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.