[solved] Ipv6 not working via router

Hello,
So, I tried what I could find online but this just wouldn't work.

Simple setup lan to wan. ISP router>> openwrt >> wired + wireless clients.

Ipv6 works when clients are connected to ISP router, but does not when connected to openwrt. I don't know much about ipv6. How do I make this work?

Here is my config:

> uci export network; uci export dhcp; uci export firewall; \
> head -n -0 /etc/firewall.user; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
> ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; ifstatus wan6
{
        "kernel": "5.10.146",
        "hostname": "OpenWrt1043ND",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link TL-WR1043ND v4",
        "board_name": "tplink,tl-wr1043nd-v4",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.2",
                "revision": "r19803-9a599fee93",
                "target": "ath79/generic",
                "description": "OpenWrt 22.03.2 r19803-9a599fee93"
        }
}
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd57:2321:0026::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.3.10'
        option netmask '255.255.255.0'
        option ip6assign '64'
        list dns '192.168.0.1'

config device
        option name 'eth0.2'
        option macaddr 'd4:XXXXXXX29:9d'

config interface 'wan'
        option device 'eth0.2'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.0.19'
        option gateway '192.168.0.1'
        list dns '192.168.0.1'
        option delegate '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0.2'
        option reqaddress 'try'
        option reqprefix 'auto'
        option ip6assign '64'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ndp 'relay'
        option ra 'relay'
        option dhcpv6 'relay'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'
        option start '100'
        option limit '150'
        option leasetime '12h'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '3'


config dhcp 'wan6'
        option interface 'wan6'
        option master '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'
        list src_ip 'fc00::/6'
        list dest_ip 'fc00::/6'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'
        list src_ip 'fe80::/10'
        list src_ip 'fe80::/10'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'


head: /etc/firewall.user: No such file or directory
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::d66e:XXXXXXX:299c/64 scope link 
       valid_lft forever preferred_lft forever
45: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 240XXXXXXX66e:XXXXXXX:299d/64 scope global dynamic noprefixroute 
       valid_lft 4774sec preferred_lft 4774sec
    inet6 fd5XXXXXXX6::1/64 scope global deprecated dynamic 
       valid_lft 6873sec preferred_lft 0sec
    inet6 fe80::d66e:XXXXXXX:299d/64 scope link 
       valid_lft forever preferred_lft forever
47: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd5XXXXXXX6:1::1/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fd5XXXXXXX6::1/64 scope global deprecated dynamic 
       valid_lft 6677sec preferred_lft 0sec
    inet6 fe80::d66e:XXXXXXX:299c/64 scope link 
       valid_lft forever preferred_lft forever
49: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::d66e:XXXXXXX:299c/64 scope link 
       valid_lft forever preferred_lft forever
default from 2405:XXXXXXX:78::/64 via fe80::XXXXXXX:c9bd dev eth0.2  metric 384 
240XXXXXXX0a8:1 dev eth0.2  metric 1024 
2405:XXXXXXX:78:691a:becd:3d54:f710 dev br-lan  metric 1024 
2405:XXXXXXX:78::/64 dev eth0.2  metric 256 
unreachable 2405:XXXXXXX:78::/64 dev lo  metric 2147483647 
fd5XXXXXXX6::/64 dev br-lan  metric 256  expires 0sec
fd5XXXXXXX6::/64 dev eth0.2  metric 256  expires 0sec
fd5XXXXXXX6:1::/64 dev br-lan  metric 1024 
unreachable fd5XXXXXXX6::/48 dev lo  metric 2147483647 
fe80::/64 dev eth0  metric 256 
fe80::/64 dev eth0.2  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev wlan0  metric 256 
local ::1 dev lo table local  metric 0 
anycast 2405:XXXXXXX:78:: dev eth0.2 table local  metric 0 
local 240XXXXXXX66e:XXXXXXX:299d dev eth0.2 table local  metric 0 
anycast fd5XXXXXXX6:: dev br-lan table local  metric 0 
anycast fd5XXXXXXX6:: dev eth0.2 table local  metric 0 
local fd5XXXXXXX6::1 dev br-lan table local  metric 0 
local fd5XXXXXXX6::1 dev eth0.2 table local  metric 0 
anycast fd5XXXXXXX6:1:: dev br-lan table local  metric 0 
local fd5XXXXXXX6:1::1 dev br-lan table local  metric 0 
anycast fe80:: dev eth0 table local  metric 0 
anycast fe80:: dev eth0.2 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
anycast fe80:: dev wlan0 table local  metric 0 
local fe80::d66e:XXXXXXX:299c dev eth0 table local  metric 0 
local fe80::d66e:XXXXXXX:299c dev br-lan table local  metric 0 
local fe80::d66e:XXXXXXX:299c dev wlan0 table local  metric 0 
local fe80::d66e:XXXXXXX:299d dev eth0.2 table local  metric 0 
multicast ff00::/8 dev eth0 table local  metric 256 
multicast ff00::/8 dev eth0.2 table local  metric 256 
multicast ff00::/8 dev br-lan table local  metric 256 
multicast ff00::/8 dev wlan0 table local  metric 256 
0:      from all lookup local 
32766:  from all lookup main 
lrwxrwxrwx    1 root     root            16 Oct 15  2022 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root             0 Feb 20 12:23 /tmp/resolv.conf
-rw-r--r--    1 root     root           131 Feb 20 12:23 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root           131 Feb 20 12:23 resolv.conf.auto
==> /etc/resolv.conf <==

==> /tmp/resolv.conf <==

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface lan
nameserver 192.168.0.1
# Interface wan
nameserver 192.168.0.1
# Interface wan6
nameserver 240XXXXXXX0a8:1
{
        "up": true,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "uptime": 246,
        "l3_device": "eth0.2",
        "proto": "dhcpv6",
        "device": "eth0.2",
        "metric": 0,
        "dns_metric": 0,
        "delegation": true,
        "ipv4-address": [

        ],
        "ipv6-address": [
                {
                        "address": "240XXXXXXX66e:XXXXXXX:299d",
                        "mask": 64,
                        "preferred": 4774,
                        "valid": 4774
                }
        ],
        "ipv6-prefix": [

        ],
        "ipv6-prefix-assignment": [

        ],
        "route": [
                {
                        "target": "2405:XXXXXXX:78::",
                        "mask": 64,
                        "nexthop": "::",
                        "metric": 256,
                        "valid": 4774,
                        "source": "::/0"
                },
                {
                        "target": "::",
                        "mask": 0,
                        "nexthop": "fe80::XXXXXXX:c9bd",
                        "metric": 384,
                        "valid": 3586,
                        "source": "240XXXXXXX66e:XXXXXXX:299d/64"
                }
        ],
        "dns-server": [
                "240XXXXXXX0a8:1"
        ],
        "dns-search": [

        ],
        "neighbors": [

        ],
        "inactive": {
                "ipv4-address": [

                ],
                "ipv6-address": [

                ],
                "route": [

                ],
                "dns-server": [

                ],
                "dns-search": [

                ],
                "neighbors": [

                ]
        },
        "data": {

        }
}

I'm no IPv6 expert either but I have a very similar config as yours (on a Mini PC).

Could you try to replace under config interface 'wan6'

with

option delegate '0'

I also have that same option on the lan interface.

Thanks for reply,
I just did, and nothing changed. Just for info, this is how it looks.
image

Is this a windows pc behind your OpenWrt router ?
What does not work ?
Can you ping your router in IPv6 ?
Can you ping your ISP router in IPv6 ?

Yes, windows pc, no internet for ipv6. I can't ping anything in ipv6 from pc but I can from Openwrt cli itself.

Can you ping your IPv6 Upstream Address ?


(in my case, it's the one that starts with 2a02 and ends with bb8b)

Yes, I'm able to ping IPv6 Upstream Address.

C:\>ping -6 google.com
Ping request could not find host google.com. Please check the name and try again.

C:\>ping -6 google.com
Ping request could not find host google.com. Please check the name and try again.

C:\>ping -6 24XXXXXXX:fed0:299d

Pinging 24XXXXXXX:fed0:299d with 32 bytes of data:
Reply from 24XXXXXXX:fed0:299d: time<1ms
Reply from 24XXXXXXX:fed0:299d: time<1ms
Reply from 24XXXXXXX:fed0:299d: time<1ms
Reply from 24XXXXXXX:fed0:299d: time<1ms

Ping statistics for 24XXXXXXX:fed0:299d:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\>ping -6 24XXXXXXX:fed0:299d

Pinging 24XXXXXXX:fed0:299d with 32 bytes of data:
Reply from 24XXXXXXX:fed0:299d: time<1ms
Reply from 24XXXXXXX:fed0:299d: time<1ms
Reply from 24XXXXXXX:fed0:299d: time<1ms
Reply from 24XXXXXXX:fed0:299d: time<1ms

Ping statistics for 24XXXXXXX:fed0:299d:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\>ping ipv6.google.com
Ping request could not find host ipv6.google.com. Please check the name and try again.

Still no internet
image

It could be a DNS problem. Try to ping google DNS using one of its address.

ping 2001:4860:4860::8844

Try to define DNS to your wan6.

config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option peerdns '0'
list dns '2606:4700:4700::1111'
list dns '2606:4700:4700::1001'
option delegate '0'

1 Like
C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
Reply from 2001:4860:4860::8844: time=31ms
Reply from 2001:4860:4860::8844: time=33ms
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
Approximate round trip times in milli-seconds:
    Minimum = 31ms, Maximum = 33ms, Average = 32ms

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

How should I interpret your ping attempts ? That it works sometimes ?

The problem could be between your windows PC and your OpenWrt router or between your OpenWrt router and the Internet.

From you PC, try a ping -v to your router to see if it gives a 0% loss after a minute.

1 Like

It's weird I know,
Something is seriously wrong here.

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
Reply from 2001:4860:4860::8844: time=32ms
Reply from 2001:4860:4860::8844: time=31ms
Reply from 2001:4860:4860::8844: time=38ms
Reply from 2001:4860:4860::8844: time=32ms

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 31ms, Maximum = 38ms, Average = 33ms

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
Reply from 2001:4860:4860::8844: time=32ms
Reply from 2001:4860:4860::8844: time=32ms
Reply from 2001:4860:4860::8844: time=32ms
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
    Minimum = 32ms, Maximum = 32ms, Average = 32ms

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

It's like the router is trying something but fails and reverts then does it again and repeats this cycle then stops.

1 Like

Ping general failure is usually Windows-specific. Have you tried on any non-Windows clients for comparison?

Also, try a traceroute to the same DST IPs.

(Edited to remove incorrect comment about other poster's screenshot.)

1 Like
C:\>tracert 2001:4860:4860::8844

Tracing route to dns.google [2001:4860:4860::8844]
over a maximum of 30 hops:

  1  Transmit error: code 1231.

Trace complete.

C:\>tracert 2606:4700:4700::1111

Tracing route to one.one.one.one [2606:4700:4700::1111]
over a maximum of 30 hops:

  1  Transmit error: code 1231.

Trace complete.

C:\>ping 2001:4860:4860::8844

Pinging 2001:4860:4860::8844 with 32 bytes of data:
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.
PING: transmit failed. General failure.

Ping statistics for 2001:4860:4860::8844:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Works fine when done using openwrt CLI

root@OpenWrt1043ND:~# ping ipv6.google.com
PING ipv6.google.com (2404:6800:4009:828::200e): 56 data bytes
64 bytes from 2404:6800:4009:828::200e: seq=0 ttl=118 time=30.126 ms
64 bytes from 2404:6800:4009:828::200e: seq=1 ttl=118 time=36.549 ms
64 bytes from 2404:6800:4009:828::200e: seq=2 ttl=118 time=29.376 ms
64 bytes from 2404:6800:4009:828::200e: seq=3 ttl=118 time=30.592 ms
64 bytes from 2404:6800:4009:828::200e: seq=4 ttl=118 time=29.919 ms
64 bytes from 2404:6800:4009:828::200e: seq=5 ttl=118 time=30.027 ms
64 bytes from 2404:6800:4009:828::200e: seq=6 ttl=118 time=29.033 ms
64 bytes from 2404:6800:4009:828::200e: seq=7 ttl=118 time=30.964 ms
^C
--- ipv6.google.com ping statistics ---
8 packets transmitted, 8 packets received, 0% packet loss
round-trip min/avg/max = 29.033/30.823/36.549 ms
root@OpenWrt1043ND:~# traceroute ipv6.google.com
traceroute to ipv6.google.com (2404:6800:4009:828::200e), 30 hops max, 72 byte packets

1 Like

Well...at least we know DNS is working.

  • Have you tried a non-Windows client yet?

The fact you got replies from Google (albeit 50%) and that it works on the OpenWrt - should suggest the need to verify the Windows client's IPv6 settings.

  • Can you ping the Windows machine from the OpenWrt?
  • Have you altered the Windows IPv6 firewall or network settings in any manner?
  • Have you follow the troubshooting steps for General Failure on a Windows machine yet?

Also, troubleshooting sites suggest resetting the TCP/IP stack of Windows.

This is troubling, my pc and android phone are connected to openwrt, yet no ipv6 assigned to them.

I tried pinging with android terminal, I got
Network is unreachable

Although there's any ip showing in openwrt that is assigned to pc, but from what I got from network settings.

root@OpenWrt1043ND:~# ping 2405:XXXXXXX7b13:c81a:790
PING 2405:XXXXXXX7b13:c81a:790 (2405:XXXXXXX7b13:c81a:790): 56 data bytes
^C
--- 2405:XXXXXXX7b13:c81a:790 ping statistics ---
16 packets transmitted, 0 packets received, 100% packet loss
root@OpenWrt1043ND:~# ping -6 2405:XXXXXXX7b13:c81a:790
PING 2405:XXXXXXX7b13:c81a:790 (2405:XXXXXXX7b13:c81a:790): 56 data bytes
^C
--- 2405:XXXXXXX7b13:c81a:790 ping statistics ---
128 packets transmitted, 0 packets received, 100% packet loss

It's just stays stuck unless I close it ctrl + c.

At the hardware level, how is your PC connected to the router ?
Is the problem the same in WiFi and Ethernet ?

As lleachii mentionned, you should really test with another device if you can.

1 Like

BTW, Androids don't use DHCPv6, they use SLAAC. Windows can use it as well.

Although if you haven't disabled DHCPv6 on your OpenWrt LAN interface, it should be working for Windows.

pc connected with router using lan cable, same problem with wifi as well.
I will try with linux.

This is normal that you don't seen anything here in OpenWrt as your are operating it in relay mode. Your ISP router should distribute the needed addresses. Can you connect to it to check ?

Hummm.

I wonder now if the OP has ever tried setting it up normally?