[Solved] How to correctly change router LAN's IP address?

I always load via serial/tftp to avoid bricking (been there and back a bunch of times via the gui)

Totally lost. As you see above, it works.

  • Would you be willing to make screenshots or a video of your problem?
  • Were you making more complex configurations than a simple change in LAN IP?

Not sure what this means in relation to the topic.

I agree it works on YOUR equipment. It doesn't work for me or the OP as stated. Just a simple change to the router subnet to not conflict with the At&t modem/router. My experience 10+ years Cable Dog; 9 years Enterprise Network Engineer if that helps resolve some silent questions.

I'll try tomorrow to replicate my steps. NON-ECC based devices (in my experience) usually tend to suffer from erroneous mishaps.

Yes...this would present a major issue, once the ARP table saw the same IP on WAN.

I would suggest making the WAN change before connect to equipment with a conflicting IP. It could also be that your devices suffer from "switch leaking" when the network resets. Some devices experience getting an upstream IP before the device boots up.

OK Bro! It does, I apologize if you thought I was talking down to ya!

I do believe I've seen this in the console messages in the very early stages of bootup.

OK Bro! It does, I apologize if you thought I was talking down to ya!

No worries

I would suggest making the WAN change before connect to equipment with a conflicting IP

I agree

You might see the switch resetting; but I'm referring to the downstream clients on the device's internal switch, upon the reset of network getting an upstream IP. As if it were an unmanaged switch.

Just to sum up, I am facing the same exact problem with Xiaomi Mi WiFi 3G

According to a certain someone, it's not possible in this realm of existence :see_no_evil::hear_no_evil::speak_no_evil:

According to a certain someone, they were supposed to:

We are awaiting your details.

Perhaps @heimdhall will be willing to show us, so we can proceed.

EDIT: I have not yet found a device that exhibits this problem, all work as I described. It would really help to actually see a device with the issue, instead of just saying so. I'm not hurt because you won't show screenshots.

If rollback feature has some flaw leading to IP-address loss under specific conditions, the best way to prove it would be syslog dump.
You can either save syslog to a file, or get it connecting to WAN/VPN/LAN2-interface.


1 Like

Here we have a simple case of comparing numbers and expressions.
3 are in agreement, 1 is not

3 > 1 note the symbol facing away from the smaller numeral 1 is the "greater than" symbol

We can also subtract these two figures

3 - 1 = 2                        *Note that 2 is MORE than 1*

Also using improper fractions...

 ( 3/1 x 3/3) = 9/3 = 3   >   (1/1 x 1/1) = 1  

3 members are in agreement
1 is not in agreement


  • Is that a screenshot or output of your log?
  • Is that some code related to the LuCI screen in question?

If you can stop that train-of-thought that something's "not possible in this realm of existence" according to a "certain someone" - then we can proceed. It would greatly help to provide a log or screenshot.

Your facetiousness is not helping solve the problem you claim to have. I'm sure nobody dedicating their time to providing responses to help figure out your problem - is worried about who is agreeing or disagreeing using natural numbers and fractions. Help cannot be provided until you actually SHOW something:

  • Do you have an issue with changing your LAN IP, or not?
  • If so, provide some logs or screenshots.
  • If not, you can't expect people to guess.

(One thing you could have assisted with, was to see if you had the same switch chip as the OP?)



MediaTek MT7621AT

This post didn't list device, yet claims a bug. You also never provided a link to your original "claim." You simply posted a link to this thread.



Broadcom BCM4709A0

1.) I really can’t decide if you’re dumb as a rock or stubborn as a mule. Maybe both? 3 members including myself have expressed the same problem. I also own an Edgerouter X. Performing the same action doesn’t resolve the url, confirming the user should now enter the new ip to access the GUI. It doesn’t lock the user out completely from accessing the GUI using another ip eg to

2.) Did you ask the other 2 members to create videos, show system output logs, or submit scripts? No you didn’t. We can continue this game of wits, because I’m synical and facetious. The Alternative is to accept the FACT that there is a problem and proceed forward.

3.) I said “I’ll try”. This weekend I had family over and kids love streaming family series.


Neither, the community moved on, sir. We didn't wait for you:

I asked one:

Understandable, we didn't wait. See the new thread. This one is solved.

LOL, I tired to be civil, but as I said, the community moved on. Feel free to contribute to the new thread.

I sent you a private message. Hopefully, it better explains why some data from those experiencing the issue is needed to assist.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.