Change LAN IP from Luci do not apply

I have an old TP-Link TL-WR741N/ND v4 already running OperWRT OpenWrt 18.06.8 r7989-82fbd85747 / LuCI openwrt-18.06 branch (git-20.029.49294-41e2258).

Now i got a TP-Link Archer C50 and installed OpenWrt 19.07.2 r10947-65030d81f3 / LuCI openwrt-19.07 branch git-20.057.55219-13dd17f. But i cannot change LAN IP through Luci. After click on apply, it says no comunication and rollsback. And never finish the roll back, so, i don't get the options "apply unchecked", but if you try the old IP after some time, is works. So i changed the IP via SSH directly at /etc/config/network

Looks like this post, but i didn't got a fix.

I tried it also by plugging the cabe just between PC and the router. Same problem.

This is not a big issue since it's rare to chenge the LAN IP, but it's still a issue. Or am i doing wrong?

LAN and WAN are not on the same subnet (WAN is PPPoE).
After i apply new LAN IP, even if i set the new subnet at PC, it still do not ping new LAN IP even once.

Had checked some threads but the only solution is to edit /etc/config/network.


The default LAN IP of OpenWrt is 192.168.1.1.

If a user changes that IP in LuCI, this is deliberately designed to ensure that the new IP is accessible by the device after the user applies the change.

If you are confident that the new IP is correct, you have a few options around that. Please refer to page https://openwrt.org/faq/change_lan_ip

Thankyou. Got it.

In fact, i'm changing subnet. The problem is that the dialog box "Apply Unchecked" do not show. When/where should it appears?

I had tried already having 2 IPs. On by cable (old subnet) and one by Wifi (new subnet). But i still couldn't reach the new LAN IP. I made the change pinging both old and new IP but new one never respond. I´ll try again just do be sure. (By the way it's already working). Next i will install Open WRT on my Xiaomi MiWifi. Maybe it would be wiser to use the default open WRT subnet.

Can you describe what you want to achieve? You mentioned that you want to create a second subnet... what will that subnet be used for (for example, some people just like to have wifi on a separate subnet vs wired, other people are looking to create a guest or IoT network or something).

If you're looking to put wifi devices on a separate network relative to wired, this can be done, but it can at times make certain things more complicated (such as file sharing, printing, streaming media from one device to another, etc.).

Sure. I don't want 2 subnets. It's just my main router (and another dumb AP, and also this one before flashing OpenWRT) is on another subnet. So it's easier to change just one. But i will end up putting all in the OpenWRT default. I will now try to get some time to flash the Xiaomi router.

Lot of text, do you just want to change the LAN IP on your OpenWRT box and the changes doesn't apply and keeps rolling back? Just change the LAN IP using SSH. Use SSH to login to your OpenWRT.

Edit the configuration directly

vi /etc/config/network

Adjust the line (press i to enter INSERT mode to write)

[..]
config interface 'lan'
        option ipaddr '192.168.200.1'
[..]

Press esc to leave INSERT mode and write :wq to save and quit VIM. Restart the network interface.

/etc/init.d/network restart

Alternatively, use the UCI interface

uci set network.lan.ipaddr='192.168.200.1'
uci commit 
/etc/init.d/network restart

I can't really grasp what you want to achieve. Yes - it's a bug. The rollback option should check the new set IP if the LAN address changes. It doesn't, and therefore the changes are reverted. No, you can't use the same subnets on your OpenWRT router and the upstream router. It's not how IP networking works, especially if the downstream router needs to communicate with the upstream router.

If you want to avoid two subnets, take a look if it's possible to run your upstream router in some kind of bridge mode so it's running like a modem. Or just disable DHCP on the upstream router and let your OpenWRT handle the DHCP. In that case, run your upstream router on 192.168.1.1/24 and OpenWRT on 192.168.1.2, and just connect your OpenWRT router to your upstream router via a normal ethernet port and not the WAN port.

But there's really no problem to run the upstream router on 192.168.1.1/24 and the downstream router on 192.168.2.1/24 and two subnets.

If i don't write details, some complain about a lack of info. Sorry if i texted too much.

That's what i did. It's in my first post.

I don't need or want 2 subnets and don't need or want a upstream/downstream router. I just have one main router and 2 dumb APs.

1 Like

Wait, so your OpenWRT router is directly connected to a modem with the WAN side configured as PPoE? Post a screenshot of the status page in LuCI.

I don't have a modem. My internet is a network cable that provides a PPPoE connection. It's on WAN port of my main AP (Xiaomi - 192.168.0.254). I have 2 others APs (dumbs 192.168.0.253 and 192.168.0.252) connected by cable to main AP, all using LAN port. That all. The only problem was that, after i flashed Open WRT to one of this dumb AP, it became 192.168.1.1 and, when i try to change to 192.168.0.253 using Luci, i got no success. I already did it using SSH and it's working as i want now.

Internet provider ----- PPPoE ------- Xiaomi WAN port ---- Xiaomi LAN port ------- Dumb AP 1 LAN port and Dumb AP2 LAN port.

Yeah that's a the correct way to set up an PPPoE connection. No need for double subnets indeed. Sorry I was confused.

So to understand it correcly, you only came here to tell us that LuCI has this weird behavior when changing IPs, and you already have solved the problem by using SSH :grin: ?

How about just using dynamic IP (cable or WiFi like normal), but as soon as you apply the change you disconnect and reconnect to get a new IP, and then you edit the browser address to the new IP.

Sort of. Maybe i was doing something wrong. Anyway i'm not getting the message box "apply unchecked". It's because the previous version (on my older dumb AP) do not have this behavior and i got confused.

I had tried to access by new IP but even ping was working on new IP. It was like "dead" and i had to wait some time (much more than 90 seconds) before old IP started to answer. I will make some tests this weekend and let you know.

I think this means that there is something wrong beyond any issue with the GUI.

I just installed Oper WRT on my Xiaomi Mini. So, as i told, now all my 3 APs are Open WRT and i decided to use the default subnet (192.168.1.x). But i want the last IP to the main router (192.168.1.254). I changed it (from 192.168.1.1 to 192.168.1.254) and other things like SSID, security, WAN and apply. It had the same behavior (reverted ALL the config) . No message box "apply unchecked". So i changed all but LAN IP before and tried again (maybe i'm to used to 192.168.0.254 and inserted it by the habit). This time i was sure to insert 192.168.1.254. IP final 254 respond while final 1 stopped. After some time, same error but this time at least i got the "apply unchecked" box and it worked. I got that this is to avoid inserting an IP that i could not have access (which could be a big problem if i'm remote). But looks like it's not working at all, even with IPs in the same subnet.

I will now change the TP-Link subnet to 192.168.1.x and check the behavior.

Ps. no game for me. Same problem. Even to set LAN to DHCP client do not work using Luci. What's the deal? Do Luci have to receive a connection on new IP in order not to roll back?

What happens if you edit the IP address in the broker address bar to the new address (before the 30 seconds end)?

It work's fine. And changes remains.

1 Like