[SOLVED] Flashing MR18 and latest up to date firmware

Has anyone successfully flashed a MR18 that has the latest up to date firmware installed?
On my device its showing "bootsh build 25-201804051805-G885d6d78-dhow-rel". Im getting to the Meraki prompt with a UART cable but whatever I type, Im greeted with "UNRECOGNIZED COMMAND LOGGED TO CLOUD SERVERS"
Ive searched everywhere but havnt found a solution yet :frowning: One recommendation was to flash it using USB JTAG cable, but that costs as much as a new ac AP :frowning:

So if anyone has had any luck, let me know what and how did you manage to flash LEDE on to the latest firmware. Or if anyone has any other ideas to try, im all ears.

Does flashing method C work for you?

1 Like

If you're at this point, you've already booted into the Cisco OS and proceeded too far.

You should never see the Meraki OS following the instructions to flash OpenWRT.

Correction: On the MR18, it seems only method C is and offline flash where you will not see the Meraki prompt.

Actually, I did follow method C and it did not work, no matter how I tried.
BUT, what is surprising that in not one thread about flashing MR18 with LEDE, where people encounter problems with newer firmware, no one has recommended to roll back to previous firmware! A few weeks back when I first started messing around with the MR18 and flashing LEDE, I briedly looked into the "firmware rollback" topic, but a bit Googling said that it is not possible.
Yesterday I looked into the possibility again and succesfully rolled back to an earlier firmware! 25.9 I belive.
Then after the roll back, I followed method C again, got to the Meraki prompt, commands worked and Im now succesfully running LEDE :+1:
After writing the new firmware onto it and powering off-on again, I had some trouble booting into the new initramfs kernel, but after some messing around, I got to it. Should anyone encounter problems with it, let me know, I can describe how I got into the new kernel. It involved some precise timing with powering on, unplugging/plugging in the GND pin and pressing 2.
So, problem solved, case closed.

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.

@Tarts5 - You wrote on page https://forum.openwrt.org/t/solved-flashing-mr18-and-latest-up-to-date-firmware/14369/3, that you downgraded MR18 from 25.11 to 25.9. Could You write how You did it?
The original topic is closed, so I could not write there.
I entered diagnostic mode with network enabled (see: https://forum.openwrt.org/t/problem-with-flash-meraki-mr18/98388 ), can use tftp to transfer files, but I'm not sure how to use dd in this mode and if it is safe.
Thanks for reply.