Flashing Cisco Meraki MR18

My MR18 licence has now expired and tried to flash it with openwrt but got the message that "UNRECOGNIZED COMMAND LOGGED TO CLOUD SERVERS"

I understand that I have latest firmware which will not allow me to flash with the third party firmware .

As per this forum [SOLVED] Flashing MR18 and latest up to date firmware
one user managed to rollback firmware to an older version , does anyone know exact sequence I have to follow as mentioned in the forum by the user?

Here is reference to a rollback approach but only works for last 14 days

The second major change is that any upgrade performed in the last 14 days can be rolled back directly from the recent upgrades list, which will return the network and its devices to the firmware version that was in place before the upgrade

This just seems to work if:

  1. your device is new
  2. your device was proper decomissioned by the previous owner and removed from the meraki database

Even if you have created a meryki account you can't register an already (and still) registered device (you'll get a "device already in use"). Even this device is not used anymore.
So I think the rollback option is a more or theoretical one for the most of us.



I tried without success to flash via OpenOCD using a Raspberry Pi.

I was not able to get the correct commands to stop the watchdog timer, and step trough it. The device simple keeps on rebooting

I will look into a E3 Flasher method in the future.