[Solved] Find a device trying to connect to WiFi


I recently changed my Openwrt router WiFi password. I updated all of my devices except readlog shows one still trying to connect a few times an hour with a PSK-MISMATCH error.
Any tips for finding the device?
I already tried looking up the MAC address, but I get no results found.
Any ideas much appreciated.


change back to the old SSID and password, on this, or some other router/AP/cell phone hot spot, and check what device manages to connect ?


SSH in to the router and run the following...

ubus call luci-rpc getHostHints

Whatever device is not connected is likely the culprit.

It's a lot easier to spot when you assign names to your devices.

I add them in /etc/dnsmasq.conf



When you're done, restart dnsmasq to take effect.

1 Like

thank you
so simple & worked perfectly !

Although flygarn12 already deleted his mail for some reason, I still quote it, as there is a good point to preserve:

Some modern phone OSs, at least new Androids, use random MACs. That makes also setting static leases and hostnames more difficult.

(I have toggled the random MAC off for my SSIDs in the phone's settings, so that the phone gets static DHCP and DNS hostname, and is more easily visible in the routers' status screens.)

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.