[Solved] Energy-Efficient Ethernet on single interface

Hallo everyone, how can i enable Energy-Efficient Ethernet on a single interface (for example wan)?
Thanks in advance.

need to know the device / chipset...

typically ethtool will let you get/set this... but for alot of things on openwrt this creates more issues than it's worth ( generally a client/switch device thing )... and is often not available... ( you may need to recompile or edit C )

Thank you, and well i just want to give it a shot: Its a pi4 b with 2 rtl8152 nics.

ethtool --show-eee eth1
[root@dca632 /usbstick 42°]# ethtool --show-eee eth1
EEE Settings for eth1:
	EEE status: enabled - active
	Tx LPI: disabled
	Supported EEE link modes:  100baseT/Full 
	Advertised EEE link modes:  10baseT/Full 
	Link partner advertised EEE link modes:  100baseT/Full 

switch off example (on for back on may need to bring the interface up/down);

ethtool --set-eee eth1 eee off
1 Like

Or as suggested in UCI:

# in /etc/config/network

config switch_port
	option device 'switch0'
	option port '<port_number>'
	option enable_eee '1'


And for issues:


This is for the ports on a switch. What i wanted was about a single interface and i already got the right answer. But thank you anyway :slight_smile:

You're welcome.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.