[Solved] Dlink DWR-116 reverting to OEM firmware


#1

I'm confused about the process of reverting back to OEM because this guide says I have to strip the OEM image. dd bs=32 skip=1 if=original.bin of=original.trx is the command to be invoked? OK but then this is linked next to the command and it is very confusing -

If you wish to upgrade your firmware from OpenWrt without resetting to stock first then you might get:

So does this imply I shouldn't strip DLINK firmware? And strip only when updating existing OpenWrt with another version? Well, that's exact opposidte of the article it was linked in.
Do I need to make this dlink firmware - https ://media.dlink.eu/ftp/products/dwr/dwr-116/driver_software/DWR-116_fw_revA1_1-06b03_eu_all_en_20160519.zip - .trx instead of .bin by stripping it or leave it as it is?

Then I need to do mtd -r write /tmp/original_firmware.bin firmware?
See? This again shows .bin and not .trx
Would that be all?


#2

"Upgrading", when mentioned in OpenWrt documents usually means upgrading to the new version of OpenWrt. So you don't need to worry about that at all. OpenWrt have 2 versions of each release: factory--that's for when you install OpenWrt on a router with stock firmware, and sysupgrade--that's for when you upgrade OpenWrt form a previous release.

By the way, the page you mentioned seems to be form support page for routers based on a totally different chipset.

According to th router page: https://openwrt.org/toh/d-link/d-link_dwr-116

To revert changes, please upload stock firmware via JBOOT recovery service.


#3

Just a "general advice", when in doubt (let that be unsure of the image or the command), I would recommend avoiding flashing via SSH. It's a bit safer to flash from the GUI.


#4

Thanks for reply.

webgui has no option to upload stock firmware.

and I don't know how to access this JBOOT

Push the reset button and turn on the power. Wait until LED start blinking (~10sec.)
Upload original factory image via JBOOT http (IP: 192.168.123.254)
If http doesn't work, it can be done with curl command:

curl -F FN=@XXXXX.bin http://192.168.123.254/upg

where XXXXX.bin is name of firmware file.

I can see a button that looks like refresh.

Eh... I did "Perform reset of configuration" or something like this in Backup/Flash tab in webgui but now the webgui stopped working. Ethernet doesn't connect. Green diodes light on the device, so at least some sign of life.


#5

So it bricked before even flashing? How can I fix it. oh boy.


#6

Ethernet cable shows disconnected on the computer? Or connected but you cannot access the router?

LAN led is on on the router?


#7

No connection on PC, diode on router lights up. There are 4 ethernet ports in the router. All work if cable plugged.


#8

That's strange. So if you keep the cable in the router, unplug it form the PC the light goes off on the router, you plug it again and the light on the router goes on again, but PC showing disconnected?


#9

Yes, exactly.


#10

And the same cable was working before?


#11

Yes. The device has become a brick. Thanks for help but I doubt there's anything that can be done about it except using some specialised rescue hardware.


#12

Not necessarily. Let's see if someone will have more info about recovering. Don't give up on the http recovery yet, and there is the serial connection.


#13

Just so that it's clearer for anybody who may be able to help. Did you just reset the configuration form LuCI (like in the image below), or what else did you do?


#14

I used the [Perform reset] button. Weird it doesn't work as that was squashfs, right? openwrt18.06


#15

if you try the JBOOT again, and set your PC IP manually to something like 192.168.123.10 for example, no access to the router still?


#16

I don't have any connection with router.
I don't really understand jboot. http://192.168.123.254?

Push the reset button and turn on the power. Wait until LED start blinking (~10sec.)
Upload original factory image via JBOOT http (IP: 192.168.123.254)

What reset button? this ip address had no http page even before brick.


#17

Screenshot%20from%202019-02-11%2013-38-32


#18

As @lleachii said.

So you will basically press that and keep pressing while you turn the power on until LED start blinking. then only then you release the rest button.

I don't know if the router in JBOOT mode will have DHCP server on or not, so it's good if you can set static IP on your PC in the range (e.g. 192.168.123.10)


#19

Thanks!
LED's are blinking constantly if I do that.
Still no connection. I might be using wrong configuration for IP.
I could use either ubuntu18 or windows10.


#20