[Solved] Dlink DWR-116 reverting to OEM firmware


#21

Just to clarify what do you mean by "no connection", do you have a red cross on the Ethernet adapter like in the picture below and it says cable unplugged, or do you mean that you just cannot access the router?

image


#22

There is a red cross on the icon.
Control Panel > All .. > Network connections is empty.


#23

That's in the tray? But in the control panel you don't see the connection? I don't know how this is possible. I would expect you to have at least three connection (LAN, Wi-Fi and Bluetooth). An if there is an issue with the card driver then how is it even showing in the tray?!

With the router on and connected to the PC by cable, could you type the following command in a command prompt (CMD) and tell us what you get?

netsh interface show interface

It would be good if you share some screens to help us understand the situation. You could also restart the PC and see if the network adapters will show up.


#24

You should get something like this

image


#25

Great. I rebooted PC and now there is yellow triangle on tray icon.

Command outputs Enabled Connected Dedicated Ethernet 2


#26

Great! Back in business then!!

Now if you set the IP as I explained, the reset and let's try JBOOT!


#27

New account as prev has reached a limit for a new account.
I flashed oem .bin file. LAN LEDs are still flashing for like 10 minutes. They used to flash like number 1,4 then 2,3. Now they do as well but 2,3 are lit for a fraction of time.
Hmm..


#28

Firmware flashing http 192.168.123.254 is still accessible (Jon Recovery System)


#29

Please refrain from doing this. Be mindful of the posting limit next time. One suggestion - only use one posting to respond to multiple posts in the thread.


#30

Well, it makes sense that the connected ports keep flashing while the empty ports stop. Though not sure why do you have two flashing ports unless you have two cables or unless it's something specific to you recovery.

Did flashing complete? (I don't have a D-Link router so I don't know what it should tell you when it's done. But after you are sure flashing is complete, you can reboot the router as normal (no reset button), set you PC IP to automatic, and your should be able to access OEM firmware interface through the default IP, username and password (those should be in the manual).

Again, make sure flashing is COMPLETE before reboot the router. Incomplete flashing could brick the router


#31

I flashed it again to get to know the process better.
While it flashes, webpage title is "waiting for a response" whereas it gets back to Jon Recovery System as 2,3 lan leds start blinking rapidly. So I plugged off the power after that.
mhegab, YOU ARE THE BEST, THANK YOU FOR HELP! It's all working fine!


#32

What is that?


#33

It is the name of 192.168.123.254 webgui.
Probably d-link specific.


#34

So now you can access the OEM firmware form 192.168.0.1?

If so, please edit the title of the topic by adding [Solved] at the beginning.


#35

Interesting. I did know that D-Link has a Recovery System, but not that it is named "Jon" on several devices.

Each day learning something new. :slight_smile:


#36

Maybe that's what the J in JBOOT stands for?