[SOLVED] DL-WRX36 issues installing Luci

I am running into this error:

Collected errors:
 * check_data_file_clashes: Package libnl-tiny2023-07-01 wants to install file /usr/lib/libnl-tiny.so
        But that file is already provided by package  * libnl-tiny2023-04-02
 * opkg_install_cmd: Cannot install package luci.

after running opkg update; opkg install luci

I have just finished rebooting with the factory image, this was the first command I typed after getting root access again.

I saw somewhere this is because it's a snapshot build and I need to update to a newer version, but am not entirely sure if that is correct or if it is, the steps to do so. I'm assuming I need sysupgrade but at this point, what are the steps to do so?

I found this thread mentioning the exact error and a solution. Will this work?

cd /tmp
wget file-url
sha256sums filename
sysupgrade filename

If that works, is it the sysupgrade file linked here that I would apply wget to?

I should also ask, assuming this is all correct, what steps do I take after all of this? Do I reattempt opkg update; opkg install luci?

grab the RC2 sysupgrade image, it should come with Luci.


or if you really want a snapshot, use
https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=qualcommax%2Fipq807x&id=dynalink_dl-wrx36, add luci to the list of packages, and DL the sysupgrade image generated.

Thanks for the quick reply. Would the steps listed work with that link? Or is there a different process?

The current state of the router is exactly after booting with the factory image. I then typed pkg update; opkg install luci and it came up with the error mentioned.

misunderstood, you wouldn't need them.

Thank you. What would be the steps for the first link? wget and it'll do what it needs to do?

yeah, just wget it to /tmp and sysupgrade /tmp/openwrt-23.05.0-rc2-ipq807x-generic-dynalink_dl-wrx36-squashfs-sysupgrade.bin

one more thing,

stop the wpad service 1st, there was an issue with sysupgrading before, don't know if it's fixed or not.

1 Like

I am sorry for the questions but if you remember, I already bricked it once and want to avoid that headache.

The exact steps would be wget file-url inside of /tmp followed by sysupgrade /tmp/openwrt-23.05.0-rc2-ipq807x-generic-dynalink_dl-wrx36-squashfs-sysupgrade.bin

What is the wpad service and how do I stop it? Also, you say "first", do you mean before I even do the wget?

Before you run the sysupgrade.

service stop wpad should work, I guess.

root@OpenWrt:/tmp# service stop wpad
Service "stop" not found:
root@OpenWrt:/tmp# service wpad
Syntax: /etc/init.d/wpad [command]

Available commands:
        start           Start the service
        stop            Stop the service
        restart         Restart the service
        reload          Reload configuration files (or restart if service does not implement reload)
        enable          Enable service autostart
        disable         Disable service autostart
        enabled         Check if service is started on boot
        running         Check if service is running
        status          Service status
        trace           Start with syscall trace
        info            Dump procd service info

/etc/init.d/wpad stop worked although it didn't give any prompt, I confirmed it via /etc/init.d/wpad status and the output was inactive, I can proceed with sysupgrade now?

Yeah, reversed order, service wpad stop.

So I can proceed with sysupgrade once /etc/init.d/wpad status outputs inactive?

Sure, go ahead.

Just got a scare when I got

root@OpenWrt:/tmp# sysupgrade /tmp/openwrt-23.05.0-rc2-ipq807x-generic-dynalink_dl-wrx36-squashfs-sysupgrade.bin
Wed Jul  5 21:23:08 UTC 2023 upgrade: Saving config files...
Wed Jul  5 21:23:08 UTC 2023 upgrade: Commencing upgrade. Closing all shell sessions.
Command failed: Connection failed

But it seems to be booted now, I can access Luci, thanks man

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile: