[Solved] Difficulty flashing a TL-WR902AC v3 with OpenWrt

Anyone try to load up a TL-WR902AC v3 with OWT lately and have difficulties with the flash? Or other TP-Link routers?

So, having one, and I finally am traveling, wanted to get Travelmate on it to try out. After a lot of trying, I was unable to get the router to take the OWT file in a TFTP transfer. Probably me, but I've successfully installed OWT before on this router. Seems to be saying not a valid file or something in the error code. (it's been several weeks since my attempts)

I recently reflashed it back to the latest TP fw, before I tried going back to OWT again. So, that's different from before.

Wondering if they changed something, like what kind of filename it will accept? Anyone else see this issue? I'm remembering the "lock the customer out of installing 3d party FW" days, back around 2016, and then they stopped trying to prevent that. Hoping this isn't related to such.

Are you following this procedure? https://openwrt.org/toh/tp-link/tl-wr902ac_v3#installation

1 Like

Which image did you download? You need the TFTP recovery image for this to work, and then you follow the instructions in the device info page that @tmomas provided (that link also states the image file that is required, but I figured it was worth asking which image because sometimes people don't realize there is a difference).

In answer to the procedure question, yes. I was working from that page. Might be some chance I loaded a different from the TFTP image, but am pretty sure I did.

Wouldn't renaming it to tp_recovery.bin cause it to be accepted, whether it's the TFTP image or not? My issue is, at the TFTP transfer, it seems to not like the file and does not upload it.

Assuming I didn't do something like spell "tp_recovery.bin" right...

Can you see the TFTP request coming in to the server?

Will set up this weekend to try it again. It's been more than a month, so I'm a bit hazy. Pretty sure though, not seeing anything on the TFTP action log end that an attempt was made, but the error given seemed to indicate the device didn't like the filename. Which implies it did make an attempt.

Could be me misconfiguring the TFTP program, though there's not all that much to do differently. I'm using a Windows machine and the Win TFTP program. IIRC, I used the same setup to put the original TP-Link FW back on it.

We'll see when I have some time to try again and have fresh results to talk about.

You might temporarily disable the firewall on the computer doing the TFTP transfer.

That is a common issue that causes it to fail.

It's also recommended to use an unmanaged switch between the router and the computer, which avoids the link-down event, and link training.

Had a busy stretch there, might get back to this tomorrow.

I did disable Windows' firewall, and read about but didn't try changing switches. I do have a managed switch in line now. I might have had my former "dumb" switch in line earlier when I was successful. Will try again with things as they were, then swap switches if I need to. And get some actual log results as to what's going on.

Are there settings you could do on a managed switch to not have it interfere with TFTP, or whatever might be happening there?

OK, gave it a try again... now I'm not even getting error messages, not to mention log entries, in TFTP64.

Setup: Win 10 laptop, eth to unmanaged switch to Wr902ac.
Changed eth port on laptop to static IP. Disabled Windows Firewall on laptop.
Put OWT 21.02.3 tftp-upgrade version into TFTP64 directory.

Power up with reset button held till lights flash, nothing. Held down till apparent reboot, nothing.
Tried above with, just in case, nothing.
Changed TP-Link firmware from latest to a 2017 version, on theory that the old instructions maybe now don't apply. (I returned it to latest stock before my last try) Same as above, same lack of results.

Thinking I've got something wrong in my setup or my TFTP setup, at this point. Might try whatever "stock" FW that is listed on the OWT site.

Any hints on troubleshooting whether I have a good working TFTP server?

There is no "tftp-upgrade" image.... there is a sysupgrade version and a TFTP recovery image. You need the latter: link. You need to rename it, too. Be sure you're following all the directions here.

Speaking in shortcut mode there, and misspeaking as well... I am using the mentioned sysupgrade version in the procedure (openwrt-21.02.3-ramips-mt76x8-tplink_tl-wr902ac-v3-squashfs-tftp-recovery.bin) and renaming it tp_recovery.bin.

Have also tried removing the switch and going direct from laptop eth to WR902ac. No joy.
Am in process of removing and reinstalling TFTP64...

Settings I use in TFTP64 -

Then, make sure is showing in the Server interfaces dropdown before starting the transfer process -

Screenshot 2022-05-07 204213

When you click on the Show Dir button on the right, you should see tp_recovery.bin in the list of files.

Again, precision in your wording is really important. You will not be using a sysupgrade image at all. You must use the tftp recovery image. It looks like you downloaded the correct one, but please use the correct terms.

Do you have another computer? Linux, Mac? Even a raspberry pi?

Think I've figured it out, was getting some kind of error about a bind error and forbidden access to a socket... got frustrated and started searching for another TFTP server, and found that there is another on my machine! Maybe it leaves itself in the background, and fights for the port?

Any rate, tried it instead, apparently I had used it long ago on one of my C7's. And, it loaded right up. Solar Winds TFTP server. Seems to have a couple parts running in the backgroud, even though I closed the program. I will try to determine if that was the the problem.

Will also look at Old Navy Guy's slightly different config for TFTP64 than I was using, but the firmware loading issue has been taken care of. I'll try to determine if it was the Solar Winds TFTP server running in the background. Not typical Windows behavior!

Sorry for my sloppy comments, and running you down a path here...

Now I'm having fun figuring out how to get the Travelmate package to work... but that's another thread...

So, the answer to my issue is, beware of versions of tftp server software that, uncharacteristically for Windows programs, load up like a damon, and stay there in your system. It may interfere with using another tftp program in the future. Solar Winds TFTP Server was the offending program in my case, preventing TFTP64 from working properly.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.