[Solved] DHCP Server not Issuing Leases

Hi All. I'm a novice at networking and appreciate your patience. I've been running build 18.06.01 on a Linksys WRT1900ACS without issue for a couple years. I decided to remap my network to identify clients/IP addresses. I'm using client MAC's to reserve IPv4 addresses. Not static, but reserved IP's still served by the DHCP.

The remap project has taken a few days and over that time I've had some issues with the router no longer serving IP addresses. After power cycling a couple times it eventually would work again. Fast forward to this morning...I finished reserving the last of the MAC's. After hitting save and apply, the router wouldn't serve any IP's again. So I power cycled the router. No luck. Tried 4-5x and still isn't working. Also power cycled the VZ ONT. Still nothing.

Did I brick the router? I can still access via Luci. I'm not sure how or what to post to troubleshoot. Appreciate any help as I'm expecting some angry children to wake up any minute!!!

Not like this.

Use ssh to connect to the device.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; uci export wireless; uci export dhcp; service dnsmasq restart; logread -e dnsmasq

Blockquote

Thanks for the help. I followed the instructions in the SSH hyperlink and used PuTTY. I got to the shell prompt, but can't figure out how to enter my password to access the router. It won't let me type anything.

When you type your password nothing is shown on the screen, not even stars *****
Just type the password and hit enter.

Wow, I feel like a dummy. lol.

So after SSHing into the router and running output, I noticed an error. The dnsmasq did not restart due to a duplicate ip address. I changed the ip and that seemed to fix the problem!

Thank you for the quick responses and help in getting this resolved.

There was a vulnerability discovered in this release, and it was recommended to upgrade. If you have a reason to not upgrade to 19.07.2 (not that I can think of any), at least upgrade to 18.06.4 [18.06.8, thanks @trendy] .

FYI, that's called static lease.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Appreciate the heads up. I'll upgrade to 19.07.02.

Done. Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.