[Solved] Debrick TL-WDR3600

Hello everyone...
I need some help trying to recover my TPWRT3600 router, but I am seeing some errors in putty, serial communication, as if the serial port speed is wrong or the cables are bad but not. like:

The problem he's presenting isthat all leds flash at sametime, indicating corrupted firmware, right?

I started testing with 155200 and went down to 9600 and nothing working properly.

My serial / USB adapter is this one, I think it may have a problem, but testing loopback communication works correctly, like this:

I ask your help because I no longer know what to do - I recover routers normally with this serial port method (using putty) and the tftp server, but this time, I can't.

If anyone has any step by step, please share here with me.

More images:

Here I soldered the wires directly to the router board for testing and yet it didn't work out


Please try tftp push-button recovery first, if that's available to you depends on the version of the OEM bootloader installed on your device.

Your first image suggests an unreliable GND connection.


Scrambled text is either you have the RX and TX the wrong way round or your TTL connection is not solid.

Remember RX one in goes to TX the other end and the same goes for TX one end goes RX the other end.

1 Like

you can see some output strings in that pic so it will be bad soldering/connection


Hello slh, I redo the GND spot welding 3 times ... Unless the track on the board is damaged ...

Hello Solidus1983, I suspect my USB / serial adapter is not reliable ...

Hello psyborg, I redo the GND spot welding 3 times ... Unless the track on the board is damaged ...

what about tx/rx lines? your wires look thick- how long they are? have you tried this same adapter on that same board before it was bricked? i don't usually solder GND, instead just attach the wire to the USB or RP-SMA shield - these are grounded

Doesn't the square part of the UART denote voltage? If so there is the issue.

My wires are jumpers of arduino... it works with others routers in the past...
They are about 10 to 15 cm...

Could you show me where please?
I am only using RX, TX and GND according to the documentation.

Measure continuity from the ground wire to grounded parts like the antenna outer conductors.

Have you tried different baud rates? 115200 is most common but it could be 57600.

Right starting from the square and I am going on how I did my TPLink W8980 here

Square = Voltage
First = Ground
Second = RX/TX
Third = TX/RX

That's of course if you've not fried you TTL adaptor.

Come on...

If I fried my usb / serial adapter, less badly lol ..
If I fried the router serial, I will be very fucked, lol again ...

Anyway, I followed the router documentation, where I am using as follows like this image (referring to WDR4300):

https://openwrt.org/detail/media/tplink/tl-wdr4300/tl-wdr4300_labled_tty_jtag_pcb_rev-1.3_1 .jpg?id=toh%3Atp-link%3Atl-wdr4300

I will test soon again ...

Guys, thank you all for all the help so far ...

Over the weekend, I'll get my notebook, add an SSD, and install Windows 7, because I have a USB / Serial adapter that works or worked perfectly on Windows 7, but no longer works on Windows 10 so I can be sure that communication works well or not ...

In that time, I can test the communication between Windows 10 on my current desktop with my 1043nd, which works fine right now, using the USB / Serial adapter which is actually my eprom recorder and can be jumpered to function as serial port or parallel port ...

Anyway, I will still resold the pins on the WDR3600 board and test the conituity between the pin and the negative terminal of eprom to check for efficient soldering, and tighten the cable terminals again (I don't think it's bad contact). but check it out).

I have a reasonable knowledge of router recovery, but with this one, I believe I am facing some more serious problem related to the hardware used - I don't know if it's on the router board, the eprom solder on the board, the adapter used, anyway, do not know yet...

Anyway, from Brazil, a "big hug" to everyone and post news right here on this topic.

Easy way to test is use a multimeter on the square pad to see if it reads 3.3v or the last pin reads 3.3v, in fact it's always best to do that.

1 Like

Yes, I tested different speeds and the character problem kept happening ... :rage:

Do you mean TL-WDR3600?

1 Like



1 Like