[Solved] Couldn’t assign I Address to vlan interface

I’m using my Open Wrt router as a manageable switch. I want assign an ip address to vlan interface and also want use wifi in same vlan. Switch vlan tagging and untagging works fine. But I want assign an ip from that vlan to switch also and wants to use wifi on same vlan. If anyone faced something like this, please give me an idea how to fix this.

Sorry, I'm not following your question.

It sounds like you are using the device as a dumb AP + managed switch. That much is clear. However, it isn't clear what you're trying to do in terms of assigning addresses to the VLANs. Can you try to explain again? Or maybe draw a diagram?

Thank You for responding.
Alright in simple terms I created vlan on another router. I want create a bridge interface in open wrt router. And give an ip to bridge interface. Bridge interface use vlan network.

You would set the address in the general setup tab. DHCP or static address.


You should be able to assign the IP in the General Setup tab. What version are you using? Because that tab is called General Settings now.

Also it can be best to avoid using capital letters in interface name.

1 Like

Gave a static ip address.

Already gave a static address. But it not working.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
iptables-save -c; ip6tables-save -c; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*

What is upstream of this device? Are there VLANs on that device already? How is the network physically connected together (a diagram would be useful) -- are you using a trunk line between the router and this device? Are there any other devices between the main router and this one?

Please also answer the questions that @Hegabo (what version are you using, what do your config files look like)?

1 Like

Oh... I see the a problem -- you need to have the VLAN tagged on the CPU. Not sure if it is the only problem, though.


Open wrt router directly connected to the other router(the one i used to create vlan)

Other problems:

The Atheros 10/100 SoC switches do not readily handle vlan numbers higher than 15. If you are the administrator and can dictate all the VLANs to be used throughout the network, use numbers from 1-15. It is possible to connect to VLANs higher than 15 (for example you need to interface with an existing network) but that requires CLI configuration.

That name "Bridge_Vlan100" is too long. Since it is indeed a bridge (the box is checked) OpenWrt will add "br-" to the name, and then it is 17 characters long the kernel can't handle more than 15 characters. So keep names short and use lowercase. Simply "vlan100" would be appropriate.

1 Like

Thank You very much.
I’ll give it a try.

Yes that was the problem. I was just testing open wrt for a project. Everything works fine now. Thank You Man!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.