[Solved] Can't open luci after package update

Hello community,

I‘m unable to connect via luci to my router.
I did a package update with this command:

opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrade

After that, I reboot the router. If I try to open luci now, I see the folloing error:

/usr/lib/lua/luci/controller/firewall.lua:9: attempt to call global 'view' (a nil value)
stack traceback:
/usr/lib/lua/luci/controller/firewall.lua:9: in function 'v'
/usr/lib/lua/luci/dispatcher.lua:617: in function 'createtree'
/usr/lib/lua/luci/dispatcher.lua:262: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:127: in function </usr/lib/lua/luci/dispatcher.lua:126>

The router is running fine, but I hope someone can help me to bring back luci to work.

You should not upgrade packages, as it can cause this unexpected results. I would revert to the initial configuration, and configure it again.


Okay, thx. What is the bets way now? Flash new or do a factory reset?


1 Like

So, what should I say? What a fantastic piece of software. I did a backup via ssh. Soft reset and restore my backup. Everything is fine again after 15 minutes of work. Thanks for your help and in the future I know, what I should not do...


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.