[Solved] Can't install SQM "cannot install dependency tc" (iproute2 compilation is currently broken in buildbot) [Solved]

Hi, I use a XR500 with openwrt and luci GUI. But I have a problem with sqm I can't install it because tc is not found.

tc is part of the iproute2 package, which currently has compilation problems in OpenWrt master (due to a version bump yesterday).

See discussion in https://github.com/openwrt/openwrt/commit/b3a0c14824be04b40e5098f3dc5073bb4b250edf#comments

cc @PolynomialDivision

PS. the iproute2 build goes ok in private buildhosts that build iproute2 along the whole firmware, but compilation with SDK apparently has problems. And the buildbot hits that.


is the latest RC6 affected by this problem ? maybe he can try 22.03.0-RC6 :

Here is a patch fixing the SDK:

However, it is more a workaround.

I can install sqm with this. But I have another problem... I have found that my speeds have reduced by half with OpenWRT compared to my stock firmware. Everything is at default atm and I am not using sqm atm. Before I got 930Mbps now ~300Mbps. What the hell...?

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Please open a new topic with suitable topic title. Thanks! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.