[Solved]Can't deal with openwrt 22.03 firewall

have you restarted the device since making the changes?

yes,reboot or /etc/init.d/network restart
still can't figure out

let's see your /etc/config/dhcp file.

Also, did you post your complete network file previously?
BTW, the firewall is not involved here since this is all happening at L2.

ok,I'm dong .will post it ASAP
thanks a lot

####package network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd05:cf8e:94cc::/48'
option packet_steering '1'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.100.88'
option ipaddr '192.168.100.250'
list dns '192.168.100.88'

config device

###package dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option ignore '1

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

Try removing these two lines from the DHCP file dnsmasq section.

if it still doesn't work, try changing the DNS server to 8.8.8.8.

And if that still doesn't work, please post the following:

cat /tmp/resolv.conf.d/resolv.conf.auto 

not work yet,I tried DNS server to 8.8.8.8,and nameserver will be 8.8.8.8. but no lucky

root@openwrt:~# cat /tmp/resolv.conf.d/resolv.conf.auto
# Interface lan
nameserver 192.168.100.88
root@openwrt:~# uci export dhcp



package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Do you have a computer with Ethernet that you can connect to the main router (instead of the openwrt router)? If so, set the same address and network settings as you have on the openwrt router and see if it functions properly.

Don’t forget to change those settings back when you’re done, but it is worth checking to make sure there is t something happening on the upstream connection.

I just tested ,if set PC ip 192.168.100.250 .dns and gateway to 192.168.100.88.it will go online.internet will be available on pc

What is the output of:

ubus call system board

root@openwrt:~# ubus call system board
{
"kernel": "5.15.80",
"hostname": "OpenWrt",
"system": "Intel(R) Pentium(R) CPU N3540 @ 2.16GHz",
"model": "Default string Default string",
"board_name": "default-string-default-string",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "SNAPSHOT",
"revision": "r21373-aa12a0fdd1",
"target": "x86/64",
"description": "OpenWrt SNAPSHOT r21373-aa12a0fdd1"
}
}

this is Development Snapshot version ,it has same issue like openwrt 22.03 on this case

Contrary to your thread title, this is not 22.03. This is a snapshot, and snapshots can contain strange bugs.

Please install 22.03.2 (the latest stable release) and try again.

I do try it before.use linksys ea3500 router openwrt 22.03.2,download firmware from openwrt offical site.it has exact same issus.

I will do it on ea3500 openwrt 22.03.2 again

Hello @psherman
I'm really sorry for that.my fault ,I may forget it
I just tested the ea3500 openwrt 22.03 for this case.it's working
thank you very much

Glad it is working. Next time, please ensure you are using stable releases (or if you need to use a snapshot, please make that known).

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

got it.done
thanks again !

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.