[SOLVED] Can't connect to WIFI when I set a password [SOLVED]

Hello there,

First time OpenWRT user. Using a WRT1900AC version 1 here.

Going through the new GUI interface and looking around. I turned on the 2.5 WIFI antenna (We typically don't turn on 5). It defaulted to no password which was fine. I connected using my Pixel 7 to ensure all was well. It worked no problems.

So I went to add a password. I set the channel to "auto" (1 defaulted) while I was at it. Set encryption method to WPA2/WPA3 mixed as I thought it would be the best for compatibility and security combo.

After that I can see the WIFI network but when I enter the password, my Pixel 7 just tells me to check the password.

Any advice would be great!

Try WPA2 personal (PSK) instead. Mixed mode tends not to work as well.


WPA3 is known to be totally broken on mwlwifi, so WPA2/ CCMP (without 802.11w/ frame protection!) is the best you can do on this hardware.


Thank you kindly. WPA2 was the only one that worked as advised. Certainly seems that WPA3 is borked.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.