[Solved]Canon ts3380 printer cannot be find from LAN

I buy a new Canon ts3380 printer and add it into my LAN, I can only ping the PC(192.168.121.102) and Phone(192.168.121.109) in the same LAN, not the Printer(192.168.121.108), Why?
If I change to a non-Openwrt router, all three devices can find each other.

image

Check this video tutorial;
Canon TS3380 WiFi SetUp review.

If I change to a non-Openwrt router, all three devices can find each other.There must be something wrong with the Openwrt router settings

Generally, the router doesn't impact connectivity between devices on a single subnet... there are a few things that could cause these problems like wifi client isolation.

Let's see your config files:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

The process of discovering a printer on a wifi network uses avahi-utils which I don't think is in the default install:
https://openwrt.org/packages/pkgdata/avahi-utils

You can work around it by using static IP's.

Also, printers often have 2 network settings: infrastructure vs ad hoc. In ad hoc printing, your job goes directly to the printer. In infrastructure, the print job passes through the router. Ad hoc is also referred to as a "guest network" and frequently is a different network.

$ cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option packet_steering '1'

config interface 'wan'
option ifname 'eth0'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option proto 'pppoe'
option username ''
option password '
'
option keepalive '0'
option delegate '0'
option ipv6 'auto'

config interface 'lan'
option proto 'static'
option ipaddr '192.168.121.1'
option netmask '255.255.255.0'
option type 'bridge'
option ifname 'mlan0'
option dns '8.8.8.8 8.8.4.4 114.114.114.114'
option ip6assign '64'

config interface 'PPTP'
option proto 'pptp'
option username ''
option password '
'
option keepalive '0'
option auto '0'
option delegate '0'
option server '66...*'

config interface 'docker'
option ifname 'docker0'
option proto 'none'
option auto '0'

config device
option type 'bridge'
option name 'docker0'

$ cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:00/0000:00:1c.0/0000:01:00.0'
option cell_density '0'
option country 'CN'
option legacy_rates '1'
option mu_beamformer '0'
option band '2g'
option channel '5'

config wifi-iface 'default_radio0'
option device 'radio0'
option mode 'ap'
option key '****'
option ssid 'MyOpenWrt'
option network 'lan'
option encryption 'psk2'
option ieee80211v '1'
option wnm_sleep_mode '1'
option bss_transition '1'
option time_advertisement '0'

Try disabling 802.11v and these other features.

$ cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option nonwildcard '1'
option localservice '1'
option cachesize '8000'
option mini_ttl '3600'
option dns_redirect '1'
option ednspacket_max '1232'
option localuse '1'
option noresolv '1'
list server '127.0.0.1#5333'

config dhcp 'lan'
option interface 'lan'
option start '100'
option leasetime '12h'
option limit '15'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
option ndp 'hybrid'
option ra 'server'
option dhcpv6 'server'
option ra_management '1'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config dhcp 'wifi'
option start '100'
option leasetime '12h'
option interface 'wifi'
option limit '15'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

Also, what is the output of

ubus call system board

These settings dosnt work

K. Let’s see what we see from the ubus info.

After installing avahi-utils, the problem has not been solved

$ ubus call system board
{
"kernel": "5.10.134",
"hostname": "OpenWrt",
"system": "Intel(R) Core(TM) i3-4020Y CPU @ 1.50GHz",
"model": "Microsoft Corporation Surface Pro 3",
"board_name": "microsoft-corporation-surface-pro-3",
"release": {
"distribution": "ImmortalWrt",
"version": "18.06-k5.4-SNAPSHOT",
"revision": "r12320-0f9df5d7ea",
"target": "x86/64",
"description": "ImmortalWrt 18.06-k5.4-SNAPSHOT r12320-0f9df5d7ea (2022-09-11)"
}
}

This is not openwrt. It is immortalwrt.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

My God, I see. Thank you

You’re welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

(Admittedly your problem is not solved, but given that the firmware isn’t actually openwrt, it makes sense to close this thread)

After a day's hard work, I finally found out where the mistake was. The Canon ts3380 printer only accepts 2.4G N mode. If WIFI set to Legacy mode, it cannot connect routes normally. The reason why I used Legacy mode in the early stage is that OpenWrt's WIFI function set too many BUGs, and I had to compromise after trying to crash too many times. Finally, I can set up a stable 2.4G WIFI on OpenWrt, and things are perfectly solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.