[Solved] Cannot active Samba, missing Services tab

I have installed the necessary packages for samba, and looking to share my router attached usb flash drive share across the network. I found a page where it was showing that usb drive could be shared on the Services tab. I cannot find the services tab on my web interface. https://openwrt.org/docs/guide-user/services/nas/usb-storage-samba-webinterface.

Someone answered the question "Missing Services tab" but that answer is not clear to me. MIssing services tab

Can anyone please help me?

@moincse, welcome to the commnity!

Did you also install the LuCI (web GUI) app: luci-app-samba?

It won't show until you've installed the web app.

(I'm not sure how to make that more clear than the link you posted.)

Hope this helps.

1 Like

Thank you very much for addressing my issue. I forgot to attach the screenshot with all installed apps. Just uploaded it. Hopefully you will get an idea what's going on there.

(I'm not sure why you didn't say "yes".)

  • Please refrain from making major edits to the original post - it changes the context and flow of the post for future readers
  • Have you rebooted since the install?

Actually, I was confused whether luci-app-samba4 serves the same purpose as luci-app-samba, so I did not clearly say yes.
And, although I edited the original question (added screenshot), I have mentioned that in my reply, so hopefully it's ok.

I did not restart the router after installing those packages. Just restarted it, and seeing the Services tab there. Thank you very much.

1 Like

Btw all you need is install the luci-app-samba/4 it will also install everything needed for the server. You don't really need all the other packages (utils, client, admin).

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.