[Solved] Archer C7 v2 - firmware version 3.15.1 - cannot install! - Help


#1

Good morning,

A friend of mine gave me an Archer C7 v2 with firmware version 3.15.1 Build 150826 Rel.36524n. The SN stars by S/N:2158. This firmware is fromTp-link but it is limited in available options and has somekind of "locked/limited firmware" because I do not have DHCP configuration for example and cannot change region that is locked to Switzerland! I've chek the manufacturer country webpage and this firmware isn't there.

I already contact the manufacturer that answer me that this is a "specialized router" and I cannot change DHCP!!!!

I've tried all the firmware for the router that I could find (official and alternative (LEDE included)) via webage and I always get the error 18005. I also use the option to reduce the file name.

I can put the router in TFTP recovery and I can sent the firmware to the rooter cnaging name to archerC7v2_tp_recovery.bin but noting happens. It boots with the installed firmware! I also tried this method with all the firmware that I could find (LEDE, Openwrt and dd-wrt);

I am out of ideas If anyone can help I deeply appreciat it.

Thaks you very much for your work.


#2

Sounds similar to these two topics:


Check if there is something useful for you.


#3

Thanks for your help tmomas.

I did read that topics before and try to follow what is mentioned but with no luck. Via webpage I get the 18005 error and via TFTP I can send the firmwares to the router but they don't install. I have no EU, US, IL sticked to the router but I also try these firmwares (lede and official). I think i've got a international version. The strange thing is that the region option in the router is locked to Switzerland and I cannot change it! the firmware in the webpage is also diferent from the one in the routher sticker. Plese heck attached file for a print screen of the available menus that I have on the webpage router firmware!

PS: I read for a specific patch for v2 in on eof the mentioned topics but I do not understand it!
PrintWebpage
Many thanks for your help.


#4

I have the same router and there are two things you can try...

  1. Download and flash the stripped firmware from FriedZombie using the web GUI...

http://www.friedzombie.com/tplink-stripped-firmware/

If that works, you can flash either TP-Link updated firmware, or LEDE on the C7.

  1. Use a TFTP server to flash, which it appears you have tried. However, try this tutorial, which works for several TP-Link routers -

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

Failing all that, a serial flash would be the next step.


#5

I just went through this with a used C7 V2 (217...) I bought.

There are 4 different factory flash images available for the C7 V2. I just tried them one by one until one worked. I renamed them to "factory.bin" before I tried flashing each one.

Go to the link below and you should be able to find all 4 factory flash builds.
https://downloads.openwrt.org/releases/17.01.4/targets/ar71xx/generic/

archer-c7-v2-il-squashfs-factory.bin
archer-c7-v2-squashfs-factory-eu.bin
archer-c7-v2-squashfs-factory-us.bin
archer-c7-v2-squashfs-factory.bin


#6

Thank you jwoods for your help but TFTP do not work. Device ask for ArcherC7v2_tp_recovery.bin I can upload it but no flash. The same webpage version then before. Serial flash probable is too much "engineering" for me (I do not have a proper cable...and probably the skills for it).

Thanks anyway for your help


#7

Thanks chadneufeld for your help but I couldn't flash the this C7. I follow your instructions but without luck (error code: 18005). I same even try to do it by TFTP. I could upload the file to the router but no flash.

Thanks anyway. I think I am stuck with this limited firmware version 3.15.1 Build 150826 Rel.36524n :frowning:

Take Care


#8

Hi!

I have same model of Archer C7 v2, ( firmware version 3.14.3 Build 150811 Rel.67693n )
with the same problems, I'm trying various fw via tftp. Even I can load but then nothing happens.
Until now no successful charge fw, no version seems compatible
In my case I found out that it is a router provided by UPC, I think that they have put a special firmware made for UPC, in fact it has far fewer menus than the original firmware.

The search for the solution continues .. :slight_smile:
See you soon


#9

Another option, although a little roundabout, is to try flashing DD-WRT for the C7 v2, then use the DD-WRT web revert file to return to stock TP-Link.

ftp://ftp.dd-wrt.com/betas/2018/02-12-2018-r34929/tplink_archer-c7-v2/

You would use the factory-to-ddwrt.bin file.

Then, you would flash DD-WRT's web revert file to return to stock (requires that you register and log in to the forum to get access)...

https://www.dd-wrt.com/phpBB2/viewtopic.php?t=85237&sid=9f0285753a122ab20f2813bc31ca35c9

After that, you should be able to flash LEDE, or TP-Link's current firmware.

I did something similar coming from DD-WRT to LEDE.


#10

Here´s my Post from last Year that helped me. Important is the right stripped Firmware with the right name and size :slight_smile:

Quote:

It´s very easy to recover the Archer C7 by TP-Link TFTP recovery mode. Please go ahead with this Documentation -> TP-Link TFTP recovery mode and firmware (TP-Link Archer C7 V2)

Total time for Recovery: max. 10 Minutes

RecoveryFile Name for INT/EU/DE Version -> ArcherC7v2_tp_recovery.bin 16.252.928 14.04.2015 20:34 -a--

Source was from -> http://www.friedzombie.com/tplink-stripped-firmware/

Alternate Firmware-Link with tftpd32: HitMe


#11

tftp works, it does its job, the fw is loaded (ArcherC7v2_tp_recovery) but then nothing happens, even after 10min. Now I have commanded a serial adapter so as to be able to see what happens when the fw is loaded
"Connection received from 192.168.0.86 on port 3885 [17/02 14:55:21.902]
Read request for file <ArcherC7v2_tp_recovery.bin>. Mode octet [17/02 14:55:21.902]
OACK: <timeout=3,> [17/02 14:55:21.902]
Using local port 58306 [17/02 14:55:21.902]
<ArcherC7v2_tp_recovery.bin>: sent 32002 blks, 16384512 bytes in 5 s. 0 blk resent [17/02 14:55:26.743]"


#12

I also tried the two last suggestions but no flash! I can upload files via TFTP but after the nothing happens. Thank you very much for your help.


#13

The (PC?) TFTP Server has the right IP Adress?

For firmware revisions before 3.14.1 (140929), the router looks for an IP address of 192.168.1.66 and a file named ArcherC7v2_tp_recovery.bin. Firmware 3.14.1 updates the bootloader to look for an IP address of 192.168.0.66 and a file named ArcherC7v3_tp_recovery.bin even on hardware v2 units, but may also load ArcherC7v2_tp_recovery.bin. Some v1.1 units may also look for ArcherC7v1_tp_recovery.bin. The model Archer C5 looks for the file ArcherC5v1_tp_recovery.bin.


#14

Unusual for the FriedZombie firmware flash to fail...

Just to confirm, you did try flashing it from the web GUI.

What error messages do you get?


#15

Error Code: 18005
from the web GUI any image always proved this error.

I would like to try the flash via serial as soon as I get the converter.


#16

I have seen that with other TP-Link stock versions, but not with the FriedZombie stripped version.


#17

Ok I manage it and flash it via serial connection. For who is interested these are the steps.

1-Get a usb - serial adaptor (I've got this one https://tienda.siliceo.es/en/usb-serie-ttl-serial-rs232/27-usb-serial-module-rs232-uart-ttl-cable-com-port-chip-of-cp2102.html?search_query=ttl&results=15 "

2-Install the correct driver for the usb-serial adaptor and connect it to one usb port. Check the COM number via hardware properties (I think). You will need it to configure Putty.

3-Download and install Putty, download and install TFTP server;

4-To configure Putty you can use as reference this 2 youtube videos:



NOTE: just use as reference for Putty configuration, no for serial connection- please check my pictures for the connections.
Set the terminal emulator to 115200 baud, 8 bit, no parity and 1 stop bit. Do not forget to save log/sessions otherwise you will not be able to write commands

5-Open Archer C7 (remove the four screws and the upper cover (be patient...not to broke anything);

6-Now cut 3 paper clips with the same size and connect them to the router (check picture 1 and picture 2). This is a little bit tricky because I do no use soldering. You insert the clips in the holes and manage them to contact with the surface and in a way that they do not move. Server is disconnected and wireless disable.
picture1picture2

7-I download the stripped image from http://www.friedzombie.com/tplink-stripped-firmware/ and rename to something simple like stripped.bin

8-Now I use as reference this post https://forum.openwrt.org/viewtopic.php?id=57190
In particular starting from here:
-“Run a TFTP server such as TFTPD32 on 192.168.1.100, and make sure the firmware image is in the TFTP folder.
Now, you should already be connected via serial. Use a terminal such as PuTTY and connect it to your router, using the settings from the guide I linked.
Press the power button on your router, and repeatedly press "tpl" to halt the boot.
You should now be at the console. If you can read but can't write any commands, make sure flow control is off.
Finally, run these commands.
tftp 0x81000000 [name of your firmware file].bin
erase 0x9f020000 +f80000
cp.b 0x81000000 0x9f020000 0xf80000

The moment of truth:
reset


Your router should reboot with the new firmware. Now you can flash LEDE via web page.
I’ve tried normal LEDE and optimized version for C7 v2 and revert to stripped firmware. Everything went well.

Please Help:
Regarding LEDE I have an issue that is the blinking leds of the router. In router web page there is the configuration option for Leds lights but I cannot manage how to configure it to blink property. For example system light is always on, if I tried a different configuration sometimes all light are on! The router is working great but I cannot figure out he led configuration. My router lights are green but in configuration is mentioned blue!
Take care


[Solved] Bricked my Archer C7 V2.0
#18

Please open a new topic for the LED question.

Since you are now able to install OpenWrt: Can we regard this question as solved?


#19

Yes please. It is solved. Many thanks for all the help.


closed #20