[Solved]After the upgrade of Openwrt 18.06 to 19.07 the VLANs on "switch0" bricked

Hello I have the router:

And after my first upgrade of version from openwrt 18 to 19.07.0 the feature VLANs on "switch0" stopped of work and bricked my router when I try to the action below...

From this:

To this:

This worked very well before Openwrt 19. I update the firmware to 19.07.2 with hope that this problem was solved but I bricked my router and I spend all morning trying to recover...

Did anybody have this type of problem too?

Did you keep the settings over the upgrades or started fresh?
Did you try to reset to defaults and do the same?

I keep settings over the upgrades.

I reset the router and I did the same. Same problem happen.


If I click "Aply uncheck" I brick the router.

Try to flash again the 19.07.2 sysupgrade without keeping the settings.
Then upon first login try to change it without changing anything else.

I tried but it not worked.


I made one work around. I rollback the old firmware, rollback the backup file with one image that this is working and after this I upgraded the firmware to 19.07.2. But now if I change configuration will happen what I showed in the first message in this topic.
So sad. I use this feature a lot

Your problem might be the one fixed by https://github.com/openwrt/luci/commit/70b5982b4c55d1f75c5092a8b2dce3c113b425b5 which only happened after the release of 19.07.2 unfortunately.

Can you see if the problem persists after running opkg update; opkg upgrade luci-mod-network? Please clear your browser cache before testing again.

1 Like

It worked! Thanks a lot

If the problem is solved, feel free to mark the topic accordingly .

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.