Snapshot builds for MR8300

It works well on both. But I have noticed better performance and bandwidth with snapshot. This is due to kernel 5.15 and DSA.

There are no 23.x build yet but they will be forked from master snapshot someday.

I guess so. If you perform a sysupgrade, it will flash the "other" partition. Settings from 22.03 and snapshot are not compatible. So flashing between 22.03 and snapshot while keeping settings may lead to issues.


Once the bootloader has been tweaked, the device is ready for the future and still can boot any Linksys or 22.03. I have already tried several flashes this way.

1 Like

Thanks again. I just flashed 22.03 with kernel tweak. Now, ready to flash the snapshot and am just going to overwrite to the other partition and don't care about OEM anymore. Hopefully, I don't regret my decision. lol

When I tried to flash the snapshot from 22.03, I am getting a message saying that the image is incompatible based on the image version (1.0 -> 2.0). Kernel partition size must be increased. I already increased the kernel partition size and confirmed the change and did a reboot as well.

Do I have to force upgrade now?

root@OpenWrt:~# fw_setenv kernsize 500000

root@OpenWrt:~# fw_printenv

This is the error:

No, there is an issue with USB:

Please check with the current snapshot if possible.

1 Like

Are you flashing a factory or sysupgrade ?
keeping settings or not ?

I forgot about this. But as I wrote before I dontt use USB, so I don't face this issue.

Sysupgrade and NOT keeping the settings... I posted the screenshot in my earlier message. Please check it out.

Before flashing, reboot so that the bootloader tweak will be active. 22.03 should still boot.
Than flash a factory image as advised by the error message, without keeping the settings.

I did reboot and checked the bootloader setting and it looks correct. I will try the factory image and not keep the settings and still get an error saying that the image metadata not present and it's asking me to force upgrade.

EDIT: It took me back to Linksys OEM firmware after I did a force upgrade and I guess it didn't like it.

Flash from Linksys, that's what I always do. That works !
At least for the very first flash. After you may try sysupgrading.

I tried to update it to snapshot from Linksys and after a reboot, I was NOT able to login to the router. I refreshed the page and even set a manual IP ( and still could not connect. I had to switch to the other partition (OEM) and I flashed 22.03 and it works!

Couldn't get snapshot to flash. Bummer!

Default snapshot from OpenWrt doesn't have Luci installed. You can log with SSH and manually install Luci or create a custom build.

EDIT : incoming 22.03.3 just released an hour ago ! No official annoucement yet !

Really? Wow! I just spent 30 minutes to figure out. lol

The instructions say that after flashing snapshot, configure as usual. I thought was available. Hmmm...

EDIT: Found it here -

It is expected that you know that ANY snapshot doesn't have Luci embedded :wink:
With the custom image builder, you can create an image that already embeds Luci.

open a command line
ssh root@
password should be empty

opkg update
opkg install luci
opkg install luci-app-advanced-reboot

You should be able to login to the GUI now.

1 Like

Thanks. Well, I am using the snapshot on my R7800 and it has luci along with other packages.

Maybe ACwifidude is packaging it for R7800 with the build and that's why I was not aware of the manual installation. Anyways, thank you for you help and much appreciate it.

It's a custom build than.

Is it working ? I guess you own me a beer than :beers:

No, I didn't update snapshot yet as I need to replace my existing router with this one and I need internet for work. I was configuring everything offline so far.

EDIT: Flashed it now and configuring!

What wifi settings do you have? Are all the bands turned on?

For some reason, my internet speeds are NOT going above 80 - 90 Mbps on the snapshot. When I am on Netgear R7800, I get about 480+ Mbps. What could be the reason? Settings are identical between R7800 and MR8300 as both of them are running snapshot builds.

Sorry that I can't tell exactly. I just remember that I changed country code, channel, power transmit, encryption and password. So nothing offensive.
I remember performing bandwith test up to 850/900 Mbits (I have 1Gb/s) with software offloading.
In fact I don't own the device, it is in my parent's home.

I enabled software offloading in the firewall and still doesn't get over 90 Mbps. Something is preventing it from going full steam and not sure what else to change.

QOS is NOT enabled too. Just don't know where else to look...