Snapshot builds for MR8300

Do you mean this " WMM Mode Where Wi-Fi Multimedia (WMM) Mode QoS is disabled, clients may be limited to 802.11a/802.11g rates." at the bottom of the wifi config page ?
It is necessary to obtain high wifi rates.

No, WMM mode is enabled. I meant QOS, which I downloaded (luci-app-qos) and it is NOT enabled.

The snapshot on MR8300 seems solid except this low download/upload speeds (90/90) when I have 500/500 Mbps connection. Bummer!

I have never used a tri-band before and see that there are two 5GHz bands and a 2.4 GHz band. I am curious whether to set the same SSID to the two 5 GHz bands or have separate SSIDs for each? Please chime in how setup tri-bands on MR8300.

That's a policy decision only you can take, but there is no problem with using the same access credentials on all radios (and for a home setup, this usually makes most sense).

1 Like

Well you just setup the three bands just as you can do with two. You choose your policy and your goal.
In my case, I use 2.4 and one 5 GHz for short distance use, and the other 5GHz for a bridge to an AP.

How do the devices know which 5 GHz band to pick when you set the same SSID for both the 5 GHz bands?

How do devices choose between multiple (physical) APs distributing the same ESSID/ PSK?

Smart devices pick the 'best[0]' one (which doesn't necessarily mean strongest signal) - all things being equal, they may choose randomly.

[0] what exactly is considered 'best', is device dependent. Devices might even ask the AP what's best (IEEE 802.11 k/v/r), but if the AP provides this answer is something for you to configure, if the client even bothers to ask- or listen is another question.

1 Like

The reason why I was asking is when I setup the same SSID for both the 5 GHz bands, all my devices are picking the same 5 GHz band (QCA9886 5.805 GHz at channel 161) and the other 5 GHz is idling (IPQ4019 5.320 GHz at channel 64) without any device to service.

1 Like

In the end it's still a policy decision, both options are valid strategies - and some devices' decisions are everything but smart.


Btw, 2.4 GHz band is letting devices connect at 144.4 Mbit/s and NOT at 300. Any ideas what could be the reason?

Wireless, edit, advanced settings, checkbox "Force 40 MHz mode".

I have it setup that way but still some devices are connecting at 20 MHz. Maybe, a bug?


Some devices don't have 40MHz in their hardware. Some devices require a change in properties to allow it (it's not setup by default).
I assume that you are using old laptops ? Under windows you may have to change some properties for the wifi card. Use the device manager.
On this example, you will see properties about 40 MHz.

Each wifi card have its set of properties, you may have to proceed to various combination of settings, sometimes not obvious.

I have old laptops with 2.4GHz only, and they can perform up to 300 Mb/s.

It's not a windows device. It's FireTV 4K streaming device and OnePlus 8T phone. They both are relatively newer devices and were connecting at 40 MHz in ddwrt for sure.

When you force it to connect at 40 MHz shouldn't these newer devices connect at that spectrum?

If these devices are relatively new, they should manage rather 5 GHz and its faster bandwidth.
Even some new phones are limited to 72 Mb/s on 2.4 GHZ because they are 1x1 devices.

How do I create a custom build and include luci and luci-app-advanced-reboot? Do I need a linux box to build it or can be done in Windows?

Easier solution: use the online image builder.
Click on Customize installed packages, and add luci and luci-app-advanced-reboot to the list. Click on Request build. Wait. It needs less than a minute. Click on factory or sysupgrade to download. Flash.

1 Like

I see that the transmit power is less in ipq4019, max of 23 dBm where as qca9886 has a max transmit power of 30 dBm. You are saying the opposite unless 23 dBm > 30 dBm?

I increased the coverage cell density to very high, other than that it's basic settings with WPA2/PSK and set the channels to 153 (80 MHz), 1 (Force 40 MHz), and 44 (80 MHz) for the respective radios.

What are your wifi settings that give you the same throughput in WDS mode?

You may have different results according to your country regulations. I'm in France, and the qca9886 (channel 149 for example) has much less power transmit than ipq4019. I can't remember exactly the values.

I suggest to set it to auto, you will avoid DFS issues.

channel 36, HT80

1 Like

I tried WDS and the throughput wasn't great. Since I had 2 RM8300, I tried the Linksys OEM firmware in mesh mode (as this is a mesh router after all) and was blown away with the performance. I was getting almost the full speed in my study, around 450/400 out of a 500/500 connection. With powerline adapter, I was getting 190/150.

Looks like Linksys has fine tuned the mesh router setup very well!