Slow Wifi on OpenWrt, but Fast on Kinetic Nokia router

Hello, I'm a noob to OpenWrt, but I'll try to provide as much info up front as I can.

I'm currently using a Nokia Beacon 6 provided by my ISP, Kinetic, while I get my Netgear R7450 (MediaTek MT7621 ver:1 eco:3) running OpenWrt 23.05.4 r24012-d8dd03c46f up to production ready so I can return the Nokia to my ISP.

My home network topology is as follows:

Internet(Kinetic) ---> Hitron Coda-45 Docsis 3.1 cable modem with two ethernet ports ---> ethernet port 0 ---> Nokia Beacon 6; and ethernet port 1 ---> Netgear R7450

Both wifi routers are 2g and 5g capable. Both are in the same room with my PC

Enabling both wifi radios on the Netgear, set password and selected non-busy channels. I have SQM installed but not activated until I get base wifi speed up to snuff. Everything else in Openwrt is stock as flashed. I ran speedtest.net on both routers 2g and 5g with these results:

Nokia
2g 53Mbps down/23 up 5g 316Mpbs down /26 up
Netgear
2g 23Mbps down/23 up 5g 65Mbps down / 26 up

So the Netgear wifi is significantly slower than the Nokia. Is there something I should adjust in WRT to get the wifi up to at least what the Nokia is getting?

Let me know if you need more info, and thanks for any direction.

You doid not set country code on all radio devices. Best is to use auto-channel-selection in most places which figures out least noisy channel.

Run this test, result link has not got your IP
-- https://www.waveform.com/tools/bufferbloat

a/ directly where routers upstream is
b/ after router did nat
c/ wifi

1 Like

Wow, thanks for the fast response, brada4. So, I set country code and set channels back to automatic. result with speedtest.net on Netgear: 2g 45Mbps down / 5g 35 Mbps down. Using speedtest.net for these initial raw speedtests as its results are faster just to compare the routers peformance.

Have used waveform.com before, ID'd that I do have a "C" bufferbloat -- hence I setup a router with WRT with SQM. But, first, I'm not even getting raw speed as good as the Nokia yet. Not understanding what your a/, b/ c/ comments are about. Can you clarify? Thx

I asked for link to waveform result like this:
https://www.waveform.com/tools/bufferbloat?test-id=aa4a8d39-dcaf-49b5-8fe7-3cbac2c013c6

what is the test result in pc via ethernet to openwrt?

1 Like

Thanks for clarifying. So, first, test result via ethernet to openwrt: "A" 507down / 24 up
https://www.waveform.com/tools/bufferbloat?test-id=97a43658-b672-4f95-88e8-b5906fe4bc2b

Openwrt - 2g: "B" 17 down/21 up https://www.waveform.com/tools/bufferbloat?test-id=577622ba-7c7b-45a1-a9ee-61573e20c399
Openwrt - 5g: "B" 23 down/25 up https://www.waveform.com/tools/bufferbloat?test-id=678764ea-47d7-4bc5-8248-6f5850cb7f08.

Just an observation, my 5G went down significantly from 65 down to 23 down, when I set channel back to automatic. Still, 65 wasn't good anyway compared to what it could be. But I shall leave it automatic per your guidance.

Please show

ubus call system board
cat /etc/config/wireless
cat /etc/config/network
cat /etc/config/firewall

Hide secrets including last half of MAC/IP addresses.
Should be at least 200-something with AC wifi

Assuming I should run from CLI of router? I don't see where to get to CLI in menu . . .

SSH client like putty, yes, then copy to text editor like notepad++ and take away "secrets"

can you post the output of

dmesg

after restarting the router?

(via ssh)

ubus call system board
{
"kernel": "5.15.162",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "Netgear R7450",
"board_name": "netgear,r7450",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.4",
"revision": "r24012-d8dd03c46f",
"target": "ramips/mt7621",
"description": "OpenWrt 23.05.4 r24012-d8dd03c46f"

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option channel 'auto'
option band '2g'
option htmode 'HT40'
option cell_density '0'
option country 'US'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt2g'
option encryption 'psk2'
option key 'removed'

config wifi-device 'radio1'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
option channel 'auto'
option band '5g'
option htmode 'VHT80'
option cell_density '0'
option country 'US'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt5g'
option encryption 'psk2'
option key 'removed'

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd25:0dd7:6c7c::/48'
option packet_steering '1'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option device 'wan'
option proto 'dhcp'
option type 'bridge'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'
option drop_invalid '1'

config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

root@OpenWrt:~#

Upgrade to 23.05.5 , .4 version has wifi bugs esp with upload speed exceeding download one.

I downloaded and flashed the system upgrade that was available which is OpenWrt 23.05.4 r24012-d8dd03c46f / LuCI openwrt-23.05 branch git-24.086.45142-09d5a38 I note that is a .4, not a .5, which is not on offer for my router (Netgear R7450) (https://downloads.openwrt.org/releases/23.05.4/targets/ramips/mt7621/openwrt-23.05.4-ramips-mt7621-netgear_r7450-squashfs-sysupgrade.bin)

root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.162",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "Netgear R7450",
"board_name": "netgear,r7450",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.4",
"revision": "r24012-d8dd03c46f",
"target": "ramips/mt7621",
"description": "OpenWrt 23.05.4 r24012-d8dd03c46f"

Same as before systemupgrade :person_shrugging:t2:

Results 2G is a wee bit better speed, and "A" bufferbloat , but 5G is still poor in both speed and bufferbloat.

2G 32down/24up "A" https://www.waveform.com/tools/bufferbloat?test-id=1190635f-8d1a-48a9-b9c4-fdebf61885d8

5G 28down/25up "C" https://www.waveform.com/tools/bufferbloat?test-id=f824f9b9-caf9-4eb4-bb34-b1e1270f7fdc

What are your next suggestions

Please upgrade (luci-app-attendedsysupgrade if no better idea)
23.05.4 is defective, it uses only one antenna for transmission typically halving "download speed" on any device. You can also downgrade to 23.05.3 if that supports your device.

Just read up on luci-app-attendedsysupgrade. Had to install auc, no biggie, but I still do not have Attended System Upgrade on my menu, so ran auc on cli. Encouraging:

Running: 23.05.4 r24012-d8dd03c46f on ramips/mt7621 (netgear,r7450)
Available: 23.05.5 r24106-10cc5fcd00 (yeah!), but then....

Are you sure you want to continue the upgrade process? [N/y] y
unknown package '(null)' requested.
Bad message (77)
root@OpenWrt:~#

I don't see any nulls in the list of packages to be installed.

Added auc outpun in case useful. Is there a way to attach a txt file? Would be cleaner that this long list of output.

root@OpenWrt:~# auc
auc/0.3.2-1
Server: https://sysupgrade.openwrt.org
Running: 23.05.4 r24012-d8dd03c46f on ramips/mt7621 (netgear,r7450)
Available: 23.05.5 r24106-10cc5fcd00
Requesting package lists...
kmod-crypto-gf128: 5.15.162-1 -> 5.15.167-1
wpad-basic-mbedtls: 2023-09-08-e5ccbfc6-7 -> 2023-09-08-e5ccbfc6-8
kmod-usb-core: 5.15.162-1 -> 5.15.167-1
luci-app-opkg: git-24.148.43905-2891ca4 -> git-24.338.58779-24d8916
kmod-crypto-manager: 5.15.162-1 -> 5.15.167-1
kmod-crypto-ctr: 5.15.162-1 -> 5.15.167-1
kmod-nft-fib: 5.15.162-1 -> 5.15.167-1
kmod-nfnetlink: 5.15.162-1 -> 5.15.167-1
kmod-crypto-hash: 5.15.162-1 -> 5.15.167-1
kmod-nf-reject6: 5.15.162-1 -> 5.15.167-1
kmod-crypto-aead: 5.15.162-1 -> 5.15.167-1
luci-mod-system: git-24.067.01860-7a82b2f -> git-24.338.58779-24d8916
kmod-nf-flow: 5.15.162-1 -> 5.15.167-1
kmod-usb-xhci-mtk: 5.15.162-1 -> 5.15.167-1
kmod-lib-crc-ccitt: 5.15.162-1 -> 5.15.167-1
ucode-mod-uloop: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
ucode-mod-ubus: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
luci-theme-bootstrap: git-24.086.46634-1ffe078 -> git-24.338.58779-24d8916
kmod-pppoe: 5.15.162-1 -> 5.15.167-1
kmod-pppox: 5.15.162-1 -> 5.15.167-1
kmod-nf-reject: 5.15.162-1 -> 5.15.167-1
base-files: 1559-r24012-d8dd03c46f -> 1562-r24106-10cc5fcd00
kmod-nf-nat: 5.15.162-1 -> 5.15.167-1
kmod-crypto-crc32c: 5.15.162-1 -> 5.15.167-1
ucode-mod-uci: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
kmod-mt7615e: 5.15.162+2024-04-03-1e336a85-1 -> 5.15.167+2024-04-03-1e336a85-1
kmod-usb-xhci-hcd: 5.15.162-1 -> 5.15.167-1
kmod-crypto-hmac: 5.15.162-1 -> 5.15.167-1
kmod-mt7615-common: 5.15.162+2024-04-03-1e336a85-1 -> 5.15.167+2024-04-03-1e336a85-1
kmod-crypto-acompress: 5.15.162-1 -> 5.15.167-1
ucode-mod-math: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
kmod-lib-crc32c: 5.15.162-1 -> 5.15.167-1
luci-mod-status: git-24.141.29354-5cfe7a7 -> git-24.338.58779-24d8916
kmod-crypto-sha512: 5.15.162-1 -> 5.15.167-1
kmod-mt76-connac: 5.15.162+2024-04-03-1e336a85-1 -> 5.15.167+2024-04-03-1e336a85-1
libmbedtls: 2.28.8-1 -> 2.28.9-1
kmod-crypto-seqiv: 5.15.162-1 -> 5.15.167-1
kmod-nft-nat: 5.15.162-1 -> 5.15.167-1
kmod-usb3: 5.15.162-1 -> 5.15.167-1
luci-app-firewall: git-24.067.01746-69867db -> git-24.338.58779-24d8916
kmod-crypto-ghash: 5.15.162-1 -> 5.15.167-1
ucode-mod-fs: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
luci-ssl: git-23.035.26083-7550ad6 -> git-24.338.58779-24d8916
kmod-hwmon-core: 5.15.162-1 -> 5.15.167-1
ucode-mod-nl80211: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
ucode: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
kmod-crypto-ccm: 5.15.162-1 -> 5.15.167-1
kmod-nf-log: 5.15.162-1 -> 5.15.167-1
luci-proto-ppp: git-24.135.44542-f1ec9c2 -> git-24.338.58779-24d8916
luci-mod-admin-full: git-19.253.48496-3f93650 -> git-24.338.58779-24d8916
luci-base: git-24.086.45142-09d5a38 -> git-24.338.58779-24d8916
kmod-leds-gpio: 5.15.162-1 -> 5.15.167-1
kmod-gpio-button-hotplug: 5.15.162-3 -> 5.15.167-3
kmod-mt7603: 5.15.162+2024-04-03-1e336a85-1 -> 5.15.167+2024-04-03-1e336a85-1
kmod-nf-log6: 5.15.162-1 -> 5.15.167-1
kmod-mac80211: 5.15.162+6.1.97-1-1 -> 5.15.167+6.1.110-1-1
luci-proto-ipv6: git-24.086.45108-51aee90 -> git-24.338.58779-24d8916
kmod-ppp: 5.15.162-1 -> 5.15.167-1
kmod-nft-offload: 5.15.162-1 -> 5.15.167-1
kmod-crypto-null: 5.15.162-1 -> 5.15.167-1
kmod-mt7615-firmware: 5.15.162+2024-04-03-1e336a85-1 -> 5.15.167+2024-04-03-1e336a85-1
kmod-nf-conntrack: 5.15.162-1 -> 5.15.167-1
kmod-crypto-gcm: 5.15.162-1 -> 5.15.167-1
ucode-mod-rtnl: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
kmod-crypto-cmac: 5.15.162-1 -> 5.15.167-1
kmod-crypto-rng: 5.15.162-1 -> 5.15.167-1
luci: git-23.051.66410-a505bb1 -> git-24.338.58779-24d8916
kmod-nf-conntrack6: 5.15.162-1 -> 5.15.167-1
luci-light: git-23.024.33244-34dee82 -> git-24.338.58779-24d8916
kmod-usb-ledtrig-usbport: 5.15.162-1 -> 5.15.167-1
kmod-lib-lzo: 5.15.162-1 -> 5.15.167-1
kmod-mt76-core: 5.15.162+2024-04-03-1e336a85-1 -> 5.15.167+2024-04-03-1e336a85-1
luci-mod-network: git-24.111.76511-ff6b275 -> git-24.338.58779-24d8916
kmod-nft-core: 5.15.162-1 -> 5.15.167-1
libucode: 2024-07-11-1a8a0bcf-1 -> 2024-07-11-1a8a0bcf-3
kmod-nls-base: 5.15.162-1 -> 5.15.167-1
hostapd-common: 2023-09-08-e5ccbfc6-7 -> 2023-09-08-e5ccbfc6-8
wireless-regdb: 2024.07.04-1 -> 2024.10.07-1
kmod-slhc: 5.15.162-1 -> 5.15.167-1
kmod-cfg80211: 5.15.162+6.1.97-1-1 -> 5.15.167+6.1.110-1-1
Are you sure you want to continue the upgrade process? [N/y] Y
unknown package '(null)' requested.
Bad message (77)
root@OpenWrt:~#

Hang on, before you expend cycles, I figgered out how to install the luci attended systemupgrade, and invoked it. Installing the sysupgrade. Do not unpower device!

1 Like

Seems like system is hung. Upgrade ran for four hours, never completed. (apparently) I cycled power, logged back in. I'm at Firmware Version OpenWrt 23.05.5 r24106-10cc5fcd00 / LuCI openwrt-23.05 branch git-24.338.58779-24d8916

2g: 42d/24u "A" https://www.waveform.com/tools/bufferbloat?test-id=07bd4a05-79c8-41c2-8b68-27ad1b7d2918

5g:13d/25u "C" https://www.waveform.com/tools/bufferbloat?test-id=64a4bfa4-e489-4fc9-89a9-5f4e0056c8cf

Wired result?

426down/25up "B" https://www.waveform.com/tools/bufferbloat?test-id=04f142c0-0486-4436-b8ea-561340f62a18

post the output of
dmesg