Setup old router (TP-LINK WDR-3600) as transparent, unmanaged switch?

I want to setup my old TP-LINK WDR-3600 as a transparent, unmanaged switch, how do I do this?

I was able to follow a guide I found online but I am finding I am still able to identify the device on my network, one of my Plumes (I use it for Wi-Fi on my main router) is able to see the device as it is connected by ethernet to the TP-LINK. How do I setup the router so it does not appear and so instead is a layer 2, unmanaged switch?

From a default installation of OpenWrt, if you want it to be an unmanaged switch, you only need to disable the DHCP server on the LAN (to make sure it doesn't conflict with the main router's DHCP) and change the IP address of the WDR-3600's LAN to an address on the network that doesn't conflict with the DHCP range or any statically assigned devices on your network. Then connect a LAN port of your upstream router to one of the LAN ports on the 3600.

Hi I did that and the device is still being identified on my Plume app. I don't have this issue on an actual unmanaged switch.

That is because the device still has a network address.

If you remove the network address, you will not be able to change anything on the configuration at all unless you use failsafe mode. But if that is what you want, set the LAN protocol to 'none' (unmanaged).

EDIT: An alternative is to change the subnet of the LAN address to something different than your main network. So, for example, if your network is, if you make the LAN, it would not show up on your network scans.



Agreed, but it doesn't make sense to me to remove the capacity to manage it. The only option to change something after this, will be to do a factory reset.
@Gigabit, where is the issue to give an ip address to the switch ?

Actually, failsafe mode can be used to make edits to the configuration without needing to reset the router. But it is more work, for sure.

1 Like

That is a feature of an unmanaged switch.

Holding no network address also makes it unhackable.

I don't mind about being able to manage the switch, it sits there and connects wired devices to my Plume AP, I want it to be transparent - that is the whole idea.

@psherman setting the LAN protocol to 'none' seems to have done the trick, many thanks for your help.

Just to point out: it is "transparent", whether you give the LAN interface an IP or set it to "none" has no effect. Packets between devices connected to the switch are still going into one port and straight out the other without ever coming across the OpenWrt device. The only thing it does, if it has an IP address, is that it connects itself to the same switch as if it were a device hanging off one of the ports, because that is literally what it is, just connected internally.

1 Like

Glad I could help.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.