Setup house 802.11r RE305/RE200

I am looking to run openwrt on my RE305 and RE200

the RE305 will be connected by ethernet cable a switch then to 10.42.0.1(Raspberry Pi 4)

I need 802.11r fast roaming between the RE305 and RE200

most devices using this Wi-Fi are iPhone so they support 802.11r

the DHCP needs to be only from 10.42.0.1 and everything needs to be on the 10.42.0.0/24 subnet

I need device to device communication between repeaters and connected devices for airplay from iPhone to smart TV

the RE305 can only do 100Mbps over its ethernet port
my internet speed is 200Mbps, this will be fine for now, and mobile devices don't really need that speed anyway

all I really need help with is the setup of 802.11r on the RE200
I will configure the RE305 ad dumpAP

1 Like

what am I doing wrong I have lost access to LuCi again

config /etc/config/network


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3e:f999:0c20::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.42.0.211'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '10.42.0.1'
        list dns '10.42.0.252'
        list dns '1.1.1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config /etc/config/wireless


config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '2.4GHz-COX-NETWORK'
        option encryption 'psk2'
        option key '###'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'COX-NETWORK'
        option encryption 'psk2'
        option key '###'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

the device has crashed with last thing to serial log

root@OpenWrt:/# [  591.194826] mtk_soc_eth 10100000.ethernet eth0: transmit timed out
[  591.207146] mtk_soc_eth 10100000.ethernet eth0: dma_cfg:00000057
[  591.219057] mtk_soc_eth 10100000.ethernet eth0: tx_ring=0, base=01e20000, max=1024, ctx=768, dtx=0, fdx=0, next=768
[  591.239747] mtk_soc_eth 10100000.ethernet eth0: rx_ring=0, base=01e1c000, max=1024, calc=311, drx=313

Edit: Working after restarting and LuCi is back

all I need help with now is connecting the RE200, dumbAP setup first then add the STA to the RE305 then add the 802.11r

am I right with that

also I only seem to be getting around 50-54Mbps when the ethernet port is 100Mbps

First you need to establish a WDS link between the two REs. The simplest way to do this is to have the RE200 connect to the existing 2 GHz (since it is 2 GHz only hardware) AP on the RE305.

On the RE305, add option wds '1' to the 2 GHz APs or in the GUI change the mode from Access Point to Access Point(WDS).

On the RE200 first prepare it to be a dumb AP by configuring a static IP (10.41.0.212/24) and no DHCP server. Temporarily move the RE200 to where you can plug it into the switch and confirm that it works as a dumb AP with this wired connection.

Then you can add a STA(WDS) that links to the RE305 and bridges into the lan. This will allow you to disconnect the Ethernet cable and operate wirelessly. Do not have the wireless link and an Ethernet connection up at the same time, that is a network loop which will bring down the network.

RE305 and RE200 both support 5GHz
but I will start with dumb ap then

OK then you should use 5 GHz for the link if there is a good signal between them. The process is the same.

so after that do I need to add access points on the RE200 to add 802.11r

This is a weak link. The pi is a bad choice as a router as its i/o is very restrictive, requiring "all sorts of jiggery pokery" to make it work as a router.

Are you using the built in wireless on the pi? I assume it is running RaspiOS as you talk about Network manager.

Why do you think you need 802.11r, and if you do why do you think you only need it on the RE200?

If you configure 802.11r on both and if it has any effect in making user devices jump APs, then you have a more fundamental problem, in that you propose a wireless link between both.

Consider this:
If a device is moving and the signal strength is dropping to the extent it needs to jump to the other AP, then the signal between the RE200 and RE305 will also be too weak and the link will be poor.

For any chance of 802.11r to be effective, you will need an ethernet link or some other medium that gives quality interconnection (such as a "Powerline" type of connection).

Works perfectly

I am running Raspberry Pi OS and use a tp-link T3U plus with the raspberry pi

I could use powerline for the RE200 but I think the signal between the RE305 and RE200 will be an issue

the reason for needing 802.11r is before with stock I had devices having no connection for around 20 seconds

all I need now is to know why the ethernet speed seems limited
and do I setup an access point on the RE200

You have not mentioned this before. Your ethernet is slow?
My first thought (based on past experience) is that the perfectly working Rpi is the problem...

By the word "signal", do I assume you mean the speed of the powerline link?
Why do you think this? Is it between two properties each with their own electrical supply consumer units?
Or is it just between two rooms in the same house?
Have you tried a powerline link?

In effect, all 802.11r does is bump off a moving device if its signal drops below a threshold. If the device "supports 802.11r" then it will look for another bssid that it knows. If it does not support 802.11r then it will just reconnect to the original ap if it can still see it.

802.11r might help with this - or it might not, even if the user devices "support 802.11r".

You will be better off optimising the 20 seconds by relocating the two APs and tweaking the output power. This might be good enough, but regardless, this is where you need to be before even thinking about 802.11r.

What? Is that a question? If it is not an access point then what is its purpose?

2 Likes

its not, every other device connected to the switch is fine
I can get 900Mbps throughput on the ethernet

its like the RE305 is set to half duplex or something

the wireless signal to the STA

as I have said before most devices are iPhone

I was on about how to add the 802.11r access point on the RE200, the STA is connected to the RE305, but there is no broadcst from the RE200 without setting up an access point on it and enabling 802.11r

I want to echo the sentiment that 802.11r is not needed in most situations. It is a common misconception that this standard is either required for roaming or that it will dramatically increase roaming performance (reduce roaming latency, etc.).

Fast roaming (802.11r) is not required for roaming to work in general. Roaming is a client (sta mode) side operation and relies on two factors:

  1. A well tuned RF environment -- that is, the placement, channel selection and power level adjustment (i.e. reduced power) such that neighboring APs have a small region of overlap. I really like the way this video explains the process of tuning your APs (it discusses it in the context of Unifi, but it applies to all wifi).
  2. Well developed logic in the client (STA) devices to make intelligent roaming choices.

When these two things are done well, roaming can be nearly seamless at human scale, and nothing more is required in general.

802.11r adds some additional coordination between the APs and the STA devices as they move through a space to help improve the speed at which the STA can disconnect from one AP, connect to the next, and reestablish network connectivity. This only adds value if the APs have been properly tuned... if they're not well tuned, the performance may actually decrease with 802.11r. Beyond that, some devices don't work well with 802.11r enabled... in this situation, 802.11r can also decrease performance to the point of devices not being able to join or maintain a connection on the network.

Have you started with point 1 above?

3 Likes

So you think the link between the re305 and re200 will be too weak?
If so 802.11r will not help at all.

What does this have to do with not being able to use a powerline link?

802.11r has nothing to do with "broadcasting" an ssid.

Have you done any reading about 802.11r?

This would be a good starting point:

On this point -- this cannot be correct. Something is seriously misconfigured if you're unable to get an SSID to broadcast without 802.11r.

Is this device running OpenWrt?

1 Like

My house has 3 Dynalink WRX36s and one Zyxel WSM20.

One of the WRX36s is connected to my ISP router and is considered the "primary" device with DHCP, routing, DNS and so on running on it. The rest are "dumb" APs.

One of the WRX36s is connected via a wired connection to the primary.

The other two devices are using 802.11s mesh networking to get their internet backhaul to the primary.

They all advertise the same SSIDs across 2.4GHz and 5GHz and pass traffic across VLANs to segregate devices.

There's no 802.11r anywhere. It isn't needed. Wireless devices hop between APs as they need to. Maybe you should start thinking KISS, rather than trying to force large network corporate protocols into your house?

3 Likes

I was saying signal should not be an issue
but I am getting around 8Mbps on the RE200 and 50Mbps on the RE305
RE200 says -40dbm signal to the RE305

channel is good when using 112 DFS
placement should be good as well with one each end of the house, probably around 15-20m

what good is it without the SSID, no SSID no devices connected to it

you misunderstood me I was said without adding the access point there is no broadcast, the 802.11r doesn't make a difference to the broadcast

I was told I need 802.11r to improve my seamless roaming
Can't find anything on KISS

I want seamless roaming

That is not a mesh.
For roaming, the international standard is 802.11r and is supported by OpenWrt - BUT, not all user devices support it.

You might use a mesh to connect your two access points together, but this has nothing to do with roaming.

the only issue now is the speed and fact nothing is connecting to the RE200
well rarely connecting to the RE200

You were actually told that mesh is nothing to do with roaming and that 802.11r might help but first you need to tune the access points and might not even need it.

Now you are doing it again, muddying the waters and ducking and weaving when caught out making assumptions about something you have no understanding of.

Why do you not answer the question about a powerline link?

If a wireless link between the two APs is good, then a user device will also be able to link to the AP that is furthest away, so why do you need the second AP?

I'm just asking questions to help understand the possibilities....

1 Like

Keep It Simple, Stupid (KISS).

Did you watch the video I linked? You need to start with:

  • channel scan in each of the locations to find the optimal channels to use
  • set non-overlapping channels for each AP
  • adjust power levels to reduce the overlap region

And using DFS channels means that the AP must wait and listen to verify that the airwaves are clear and that it can operate safely before it will come up... it will shut down the radio if there is a "radar hit." You're best off avoiding DFS channels if you can.

Who told you this? As I explained above, it is a common misconception, and while it can improve things, it can also make things worse. You need to make sure your normal/classical roaming (without 802.11r) works reasonably well before you move on to 802.11r.

KISS = "Keep It Simple, Stupid" -- it is a principle of not over-complicating things. 802.11r is a major complication that is not needed. KISS would say that it is critical to make normal roaming work properly first.