Setup HLK-7628N kit with OpenWrt

Hello friends,
I have been working with OpenWRT on two devices that I have at home, and i am loving it!
I have one setup on a RPi42G and another on a TP-Link AP (running LEDE) that I have converted to an OpenWRT router. I have been using it so much that I have been thinking to amp the up a bit and try to install it on a dedicated device - so, I have purchased the HLK-7628N kit.

the kit came already installed with OpenWRT and I have managed ONLY to make it working on a different network from the one it came with.

The kit came with an antenna and Power Supply.
I have connected the device to my PC and managed to connect to the LuCi interface to see what it had already been configured and understand how I will have to move forward to accomplish my settings.

The settings that I want to work with are:
Wireless on the HLK to connect with my AP and provide the router and the devices connected to it with internet. That I will have to be able to configure the interface with a static IP from my main network as well. (same as I already did with my TP-Link using LEDE)

Then on the LAN it will be providing a 10.79.79.0/24 addresses, of which my PC got one after I made the simple change to the network file.

But, I have been struggling for a very long time and I am NOT able to scan and see my WiFi networks that I should be able to connect with.
I also tried to manually setup the SSID of my Wifi that I want it to connect with and provided the password as well. BUT nothing - it did not connect at all and did not get an IP address.

I have tried to do the same as I did with LEDE on my TP-Link but I have NO luck doing so, also the interface is NOT the same and it is hard to follow exactly. I have tried to add interface to connect with the wan that I manually created and with no luck at all.

I want to make this router to work with OpenWRT as I intended it to be and i would be happy to get your assistance. Not sure I do understand what I should work on to make it finding my Wifi Network. I want it to connect to my unifi AP and use it as a internet gateway for the router and the devices connected to it on LAN 10.79.79.0/24 as well.

This is my wifi settings

config wifi-device      mt7628
        option type     mt7628
        option vendor   ralink
        option band     2.4G
        option channel  0
        option auotch   2


config wifi-iface
        option device 'mt7628'
        option ifname 'ra0'
        option key 'mypassword'
        option disabled '0'
        option wmm '1'
        option apsd '0'
        option ssid 'mywifinetwork'
        option mode 'sta'
        option network 'wan'
        option encryption 'psk2+tkip+ccmp'
        option bssid 'E0:63:DA:34:33:9A'

Also when I do uci commit and wifi I get this:

root@OpenWrt:/etc/config# wifi
killall: ap_client: no process killed
kmod: module is not loaded
Failed to find hw_nat. Maybe it is a built in module ?
killall: 8021xd: no process killed
uci: Entry not found
OPTIMIZED_FOR -> wifi
NUM_OF_CPU -> 1
wifiDomain1 -> 2.4G
wifiDomain2 ->
CONFIG_RALINK_MT7621 ->
CONFIG_ARCH_MT7623 ->

That I am not sure what I see here and does it show an error? Still learning.
My network config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde6:345c:4c95::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '10.79.79.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr '0C:CF:89:2A:DE:43'

config interface 'wan'
        option macaddr '0C:CF:89:2A:DE:43'
        option type 'bridge'
        option _orig_ifname 'eth0.2 ra0'
        option _orig_bridge 'true'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config interface 'WWAN'
        option proto 'dhcp'

This is the version that it came with:

DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="Barrier Breaker"
DISTRIB_REVISION="unknown"
DISTRIB_CODENAME="barrier_breaker"
DISTRIB_TARGET="ramips/generic"
DISTRIB_DESCRIPTION="OpenWrt Barrier Breaker 14.07"
DISTRIB_TAINTS="no-all no-ipv6 busybox"
14.07

I would be happy if I can get assistance on the configuration mentioned above.
BTW is that version the most latest that I can use on that device? I wonder if I can or should upgrade it to a more recent version?

I really appreciate it.
Thanks for your help
Arye

TL; DR so only replying to the last bit: 14.07 is ancient. Since there is a stable 22.03 build, upgrading is a good idea.

1 Like

https://firmware-selector.openwrt.org/?version=22.03.2&target=ramips%2Fmt76x8&id=hilink_hlk-7628n

@andyboeh is correct -- you should upgrade to the latest before doing anything else. You probably will not be able to upgrade in one shot unless you use TFTP or similar. Instead, you will need to make several intermediate upgrades. Probably first to 17.01, then 19.07 and finally 22.03. Each upgrade should be done without saving settings -- the settings will not be compatible, so just start over from scratch and be sure to explicitly not keep settings (if you're using the CLI to upgrade, be sure to use the argument sysupgrade -n to not keep settings).

1 Like

Thanks @psherman and @andyboeh .
Doing the upgrade from the web interface is the best way of doing that, correct?
Not sure that I know how to connect to it using TFTP - So I think that I will have to take the safe route
I need to upgrade to 17.01 and then 19.07 and lastly 22.03 Correct?
I understand that this board support the latest version.
Thanks, Will try my best and hopefully I will be able to do that.

You can use the web interface or the command line -- they are both the same under the hood (but tftp is entirely different).

In the link you provided what should I be downloading the Kernel or the sysupgrade?

sysupgrade. But I provided the link for 22.03.2.... you'll need to browse for earlier versions at downloads.openwrt.org

1 Like

So I will download and update to the latest LEDE version 17.01.7 and then I will update to 19.07.10 and only then I will update to the latest, Correct? I can take the latest minor version on each or should I go with the first like 17.01.0 and 19.07.0? would that be safer to do? Thanks

Use the latest minor version of each.

1 Like

Thanks! will try that and I hope for the best.

In the link of the LEDE version I see several arch to download it - what should I chose to download?
And also I am getting no module found on old versions then 21 rc.

What architectures are you seeing?

I see this page
https://archive.openwrt.org/releases/17.01.7/targets/

You need to identify the architecture of you device.

1 Like

Thanks!! I will download it.

In this page - https://archive.openwrt.org/releases/17.01.7/targets/ramips/mt7628/
Should I download this:
mt7628-squashfs-sysupgrade.bin
And also there are supplemental files.. Not sure I know what and how to use them,

Just the main file is all you need.

1 Like

Just want to make sure before I move forward - Hope that it is OK:
these are the files that I need to download?

  • lede-17.01.7-ramips-mt7628-mt7628-squashfs-sysupgrade.bin
  • openwrt-19.07.10-ramips-mt76x8-hilink_hlk-7628n-squashfs-sysupgrade.bin
  • openwrt-21.02.0-rc1-ramips-mt76x8-hilink_hlk-7628n-squashfs-sysupgrade.bin
  • openwrt-22.03.2-ramips-mt76x8-hilink_hlk-7628n-squashfs-sysupgrade.bin
    Thanks

Yes. Looks good.

Thank you @psherman