Setting WAP IP address

Hi, I am trying to follow the tutorial [OpenWrt Wiki] Wireless Access Point / Dumb Access Point on a TP-Link TL-WDR3600 (N600). Since I already installed OpenWRT previously, I re flashed with openwrt-21.02.3-ath79-generic-tplink_tl-wdr3600-v1-squashfs-sysupgrade.bin for a clean start.

I connected LAN port of router to my computer and accessed it via LuCI http://192.168.1.1/cgi-bin/luci/admin/network/network as instructed. It looks like this

I am getting stuck here:

  1. Go to Network → Interfaces and click on the Edit button of the LAN interface. Ensure you are on the General Settings tab.

Here I am:

  1. Give the wireless AP router an IP address “next to” your main router.

I interpret these instructions as referring to the IPv4 address. Is it correct? I change the value to for example 9.10.11.12 The pending changes are listed like this:

Clicking Save & Apply begins a countdown:

until after the 90s are up, this happens:

I can only access via the original 192.168.1.1 address. When I return to it, the changes are still pending unless I clear them.

The instructions seem clear enough. There is not much here to be getting wrong. I am not sure if the correct item is selected from the menu labeled Device? These are the options:

I tried both Wireless Networks which are radio0.network1 and radio1.network1 with same result.

I guess I am doing something wrong. What is it?

Thank you for any assistance.

Contrary to your title, you appear to be setting the LAN IP address.

A few things about that...

I hope you are using 9.10.11.12 purely as an example and not actually trying to use that address in reality. You should be setting the LAN address to work within your existing network range (from your main router), and this should be an RFC1918 address. The address you use should be one that is not currently occupied on your network and that is also outside the range of the DHCP pool (as set by your primary router or whatever device has the DHCP server). Do not use random addresses.

The issue that you're having with the roll-back is addressed here:

2 Likes

fwiw, I frequently encounter the problem where I cannot change the LAN IP address on some devices, because LuCI does not offer 'Apply Unchecked' dialogue box, and so encounter the Rollback message.

SSH into the router and execute these commands to for example, change the LAN IP address to 192.168.1.2, as mentioned in the wiki page provided by @psherman

uci set network.lan.ipaddr='192.168.1.2'
uci commit
/etc/init.d/network restart

DHCP server can be subsequently turned off in LuCI etc.

1 Like

Thank you that did indeed solve it!

Now devices connected to the WAP are managed by the main router and appear to behave just the way I want.

Glad to hear it!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.