Setting up dumb AP, used WAN Port question

Hi all...newbie here (duh).

I have a running gateway, and a dumb AP. Instead of plugging in ethernet from gateway to a LAN port on the AP, I plugged it in to the WAN port.

I moved my NAS, which has a static IP address, from the gateway to the AP. I can no longer reach it via its static AP (the ip address switches when running a ping command to the static IP assigned to the NAS).

Is this the expected behavior by using the WAN port instead of a LAN port (I know, I have to read a little more in regard to the differences bewteen the WAN and LAN)?

I am also coming from DD-WRT, where this type of config (switch WAN to LAN in configuration check box) was "easier". I was unaware that there may be performance issues regarding using the WAN port as a LAN port, which I have started to read about.

TIA...Eric

If you want to make your WAN port operate as an additional LAN port, that's pretty easy to do. But you do need to make a small change that is not described in the dumb AP guide, so the behavior you are experiencing is expected. If you connect the router to the lan port of your OpenWrt dumb AP, it should work normally.

Have you already followed the dumb AP guide?

If so, we just need to see one file and we can get you running with the wan port included as 'just another lan port'

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network

I followed dumb AP guide to a tee, EXCEPT from plugging in the cable into LAN port.

I will switch it to the LAN port after work (I work remotely).

After I ensure that all is correct, I will start reading up on the topic (how to switch WAN to LAN).
I will try to get the network file later today.

Thanks!

 -----------------------------------------------------
 OpenWrt 21.02.3, r16554-1d4dea6d4f
 -----------------------------------------------------
root@ejafAP3:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdde:xxxx:xxxx::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.15.10'
        option gateway '192.168.15.1'
        list dns '192.168.15.1'

config device
        option name 'wan'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'
        option auto '0'

Output from network

Remove this section (or remove the device line from below)...

add the wan port to br-lan like this:

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'

That should do it.

Thanks! Will do it later...gotta stop working :wink:

OK...I tried to reconfigure this in LUCI.

  • Deleted the WAN interface
  • Added bridge port "wan" to Bridge Device: br-lan

In network, under devices, I see device "br-lan" and "wan" (wan has a different MAC address compared to all the others.

looking at /etc/config/network shows this:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdde:xxxxxxxxx::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'
        option bridge_empty '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.15.10'
        option gateway '192.168.15.1'
        list dns '192.168.15.1'

config device
        option name 'wan'
        option macaddr '62:xx:xx:xx:xx:90'

Have no clue what/why confog device "wan" is there, and I saw something about getting a new mac address.
I also have no idea where bridge_empty came from

If I ping the server I get this:

Pinging xxx.xxx.xx.90 with 32 bytes of data:
Reply from xxx.xxx.xx.236: Destination host unreachable.

If I ping xxx.xxx.xx.236, I get this:

Pinging xxx.xxx.xx.236 with 32 bytes of data:
Reply from xxx.xxx.xx.236: bytes=32 time<1ms TTL=128

I also switched the ethernet cable from the WAN to the LAN port, and restarted both the gateway and the AP.

Confused newbie here :blush:

Can you provide a diagram of your physical topology? Pleaes include IP addresses and the brand/model of each device.

And are these local addresses on your LAN (i.e. 192.168.1.90 and 192.168.1.236)? If so, please don't redact this data -- it's not sensitive/private, and removing it will only cause more confusion.

Finally, where are you pinging these from (the diagram will help here)... from a computer > server? router > server? Dumb AP > server? etc.

sure thing...will try to put this together tomorrow.

Thanks for the help.

E

Hope this diagram suffices

ejafGATEWAY (Linksys EA8500), running OpenWRT 21.02.3:
network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd0f:e8bf:da5c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1'

config device
        option name 'eth1.1'
        option macaddr 'c0:56:27:06:29:b5'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.15.1'

config device
        option name 'eth0.2'
        option macaddr 'c0:56:27:06:29:b5'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

ejafAP3 (Linksys WRT3200ACM), running OpenWrt 21.02.3

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdde:e79e:4e8d::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'
        option bridge_empty '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.15.10'
        option gateway '192.168.15.1'
        list dns '192.168.15.1'

config device
        option name 'wan'
        option macaddr '62:38:e0:c3:fa:90'

If anything else is needed, please let me know.

Eric

Hi all...just an update on this...

I "think" my Open WRT settings are working correctly (although I do not understand most of the settings in the network file, and why wan is still showing up on my AP).

With that said, it turns out that the host that had the static IP address is basically failing. I had to reinstall the ethernet adapter drivers, and once that was done, no issues pinging.

With that said, since this is my NAS, I am in a bit of a bind, but nothing anyone here can help me with.

Appreciate your time, and would love to learn more about that config question I have, but will try to search out answers before wasting anyone else's time.

Eric

Sorry that this one fell through the cracks.

Regarding the NAS (I assume that's the "SERVER" in the diagram) -- I don't see any reason that it wouldn't work based on the network topology you've shown... check the network settings on the NAS to make sure it is configured properly.

What is it that you still have questions about?

This one, when you mentioned I could just delete it, but I tried to move it into br-lan via LUCI, and wan shows up in the device br-lan section.

I'm not following your question...

I advised deleting the wan network interface. From there, the wan port would be available to be added to br-lan.

What you've shown is the wan device stanza -- basically just defining the wan with a specific MAC address. That should not really matter here -- it can stay.

Understood...thanks.

My only confusion, then, was the fact that when you asked me to delete it originally, I didn't feel comfortable ediiting the actual file via telnet (been a long time since I worked on linux, and at the time, I was using vi to edit shell scripts).
I figured that by moving the wan under br-lan in LUCI would accomplish the same thing. Guess it doesn't remove that in the network file.

Thanks much for the help.

Eric