Set VLAN COS Priority for Google Fiber

I would like to connect to Google Fiber directly with my Linksys WRT3200acm. I am able to do it using dd-wrt by setting the VLAN ID to 2 with a priority of 2. There is a post in the archive here about doing this with openwrt and using vconfig. Since vconfig is no longer included, I've been trying to use ip link, but have been unsuccessful so far. From the man page, it looks like I should use something like

ip link set eth1.2 vf 1 vlan 2 qos 2

but when I do that I get the response

RTNETLINK answers: Not supported

After reading another thread on the forum that seemed to be dealing with a similar issue, I tried

ip link set eth1.2 type vlan egress 0:2

but that didn't seem to work either.

Any advice would be appreciated. Thanks.

I believe you should just have to add a t to the WAN port - given that OpenWrt also uses VLAN ID 2 for WAN by default.

I think the question is how to get the vlan COS to be 2 though, not the VLAN tag itself.

In my opinion, UCI-based configuration would be the preferred approach.

Should that not be possible, it may be that the busybox version of the ip tools does not implement the required functionality. If that is the case, the ip-full package may be required.

1 Like

Thanks to everyone for their help. My connection is working now, though my upload speeds aren't what they should be. So far everyone's post has added some good information. I had tried changing the WAN port to tagged previously as suggested by lleachii, but that didn't work on its own. However, when I used ip link to change the COS bits, I didn't have the WAN set to tagged. Once I did both it started working. Also, as Jeff pointed out, it's likely you need to install the ip-full package. I didn't mention that I had already done that in my initial post.

Jeff mentioned that UCI-based configuration would be preferred. Could someone explain how to do that? In all my searching, the only thing I found about changing the VLAN priorities was by using vconfig or ip link.