"Services" does not appear


As you can see in the attached photo, I´m having problems to configure my DDNS server because I haven´t got the "Services" on the top of my openwrt,

I don´t know which package I need to donwload for "services".

¿Can you help me?

Best regards.

You're running a truly ancient version of OpenWrt... (Barrier Breaker 14.07). That has been EOL and entirely unsupported for many many years. I'm not even sure if that version had the "services" menu.

What device are you using?

ubus call system board

I´m using an old router, ALPHA ASL-26555, I have tried with a newer version but it works too slow...

That's not surprising given that the device is so old.

But given the extreme age of Barrier Breaker, you should not be using it on the internet anymore. It is just not safe. There are many potentially serious security vulnerabilities that could cause the router and possibly your entire network to be put at risk.

That version is almost 9 years old... There have been 6 major releases since 14.07. It appears that your device is supported at least through 17.01 (but that is not much better from a security perspective), and even 19.07 has been EOL and unsupported for the better part of a year.

I suggest that it is time to ecycle that device and get something that can support a modern version of OpenWrt.

1 Like

The truth is that the equipment will be for a home network in which I do not have any type of sensitive information.

Is there any way to get the services to appear? maybe with a slightly newer version?


This is not a good approach to security. You may not be holding secrets of national defense or propriatary company information on your local network, but if you use your network for anything that has an account associated with it -- i.e. email, banking, bill-pay, shopping, etc. -- you really don't want to have a vulnerable system that could be exploited. You'd be amazed how quickly things can go wrong with your personal accounts and devices if you have an issue with security.

Anyway, You should use the most modern version that is supported by your device... it seems 17.01 is listed on the device info page, but you may be able to run 18.06 or 19.07. Those are still unsupported, but at least they are closer to something current.


I´m going to try with the latest supported version and I´m going to think about a new device.

Thanks a lot.

you're welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

I tried with tle 17.01 version, but, the menu of services is not available...

Any sugestions?

Thanks a lot.

Can you upgrade to 18.06 or 19.07?

This versions are not available for my device. ¿Where can i donwload them?

Thanks a lot.

Seems to be here:

putting aside using old, out-dated and probably unsecure version for a moment, packages with names starting with luci-app- will show up in luci. you may need to logout / login to allow luci to read freshly installed configs.

so you need to opkg update ; opkg install luci-app-ddns, you may also need to install extra ddns scripts to support your ddns provider opkg install ddns-scripts-<whatever>.

please note i cannot recall how old ddns was working exactly, this is how it is split into various bits now. but the approach (i.e. using luci-app-ddns) was the same as i recall.

hope it helps.

but very much suggesting to replace your router with a recent one supporting latest owrt to keep things secure as possible.


Now, I have got the 19.07.10 version.

The "Services" are not available.

I tried to do what you say, but, I can´t do it:

root@OpenWrt:~# opkg install luci-app-ddns
Installing luci-app-ddns (2.4.9-7) to root...
Collected errors:
 * verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci-app-ddns needs 26
 * opkg_install_cmd: Cannot install package luci-app-ddns.

I don´t understand because I have got some memory...

So you've run out of flash storage space...
This will start to become a much more complex thing to achieve if you need to start freeing up space.

You're looking at RAM. The memory that is filled to capacity is the flash storage.


i am afraid what @psherman explained and https://openwrt.org/toh/alpha_networks/asl26555 describes is true: you don't have enough flash to store extra files.

time to invest into a new router.