Running OpenWrt in bridge mode on T-Mobile network

I will be changing providers at the end of the year. I now have my modem set to bridge mode and am running open-wrt on a tp-link ac1750 router. I wish to have the same setup with my new provider, but the only information I could find referred to setting up a router with its original firmware. Could someone take a look at this post and tell me what I would need to change in my open-wrt configuration to get this working? The text is in dutch, but the configuration instructions are legible.

For future reference, I have found the (untested) answer here:

This is what i was looking for.
But i need some help to make it work ?!
I know i am almost there because the Network led is burning but i have no connection on my Wifi or LAN

I just need this settings translated to this OpenWRT settings;

IPTV/VLAN inschakelen
Mode Custom
Internet Vlan ID: 300 Priority 0

I set it up like this picture, but something is wrong, Somebody ?

I have the same question.
Your help will be very appreciated!

Actually the settings where very simple in the original firmware from Netgear.

I have a picture.

This setting needs to be translated to the Openwrt firmware.

If somebody knows how ?!

The switch settings are right though you don't need to attach any VLAN to both eth ports. As with the default, connect eth0 to wan (tagged) and eth1 for lan (tagged).

The wan status should show cable plugged in. The no link / unplugged icon suggests the cable from the router to the ONT/modem is not plugged in or the modem is powered off.

Then go to network interfaces and edit the wan-- click on physical device and change from eth0.2 to eth0.300. Configure DHCP or pppoe as required by the ISP.

1 Like

Sorry for the late respons !

But i tried what you said and put the settings from the default like this (picture)
But still, no internet :frowning:

you're missing the VLAN 300 as per your original routers' settings ?

there's also Use vlan t-mobile at home